[Indicator] battery icon unreliable at low battery levels

Bug #1186181 reported by Ricky Chan on 2013-05-31
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Matthew Paul Thomas
indicator-power
Fix Released
High
Charles Kerr
indicator-power (Ubuntu)
High
Charles Kerr

Bug Description

Battery icon does not reliably display correct values at low battery levels.

The icon works fine until you get below 30%. At 10-30% a small red icon should be displayed, and another icon should be displayed at <10%. Currently, the icon doesn't seem to change to anything smaller than the 40% icon.

I have sometimes seen the red 20% icon, but it's very unreliable, and typically switches back to the 40% icon moments after resuming the phone.

Related branches

lp:~charlesk/indicator-power/1p-1186181-prefer-battery-charging-XXX-icons
Merged into lp:indicator-power/14.10 at revision 245
Ted Gould: Approve on 2014-06-11
PS Jenkins bot: Pending (continuous-integration) requested 2014-06-11
Ted Gould: Approve on 2014-05-07
PS Jenkins bot: Approve (continuous-integration) on 2014-05-05
lp:~charlesk/indicator-power/lp-1186181-icon-should-match-battery-percentage
Merged into lp:indicator-power/14.10 at revision 256
Antti Kaijanmäki: Approve on 2014-08-01
PS Jenkins bot: Approve (continuous-integration) on 2014-07-29
Sam Bull (dreamsorcerer) wrote :

Yes, they seem misleading to me. 99% looks like a 2/3 battery, 25% looks critical with nothing left. Android's battery indicator has good values.

Changed in touch-preview-images:
status: New → Confirmed
John Lea (johnlea) on 2013-08-12
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
John Lea (johnlea) on 2013-08-12
affects: touch-preview-images → unity8
Lars Uebernickel (larsu) wrote :

There are two naming schemes for battery icons: "battery-{low,good,full}" and battery-{000,020,040,060,080,100}" (and corresponding "-charging" variants). Indicator-power gives precedence to the first scheme, but always includes both. Please consult the source [1] to find out which icons are used for which percentages.

[1] http://bazaar.launchpad.net/~indicator-applet-developers/indicator-power/trunk.13.10/view/head:/src/device.c#L286

Charles Kerr (charlesk) wrote :

This is related to bug #1215520, which discusses the specific case of the charging icon being >20% misleading in the power indicator. For example, Sam's in comment #1 seems to be getting bitten by that bug.

However, the fix for bug #1215520 is to revert back to the battery-{000,020,040,060,080,100} icons that Lars mentioned. This bug seems to be requesting a finer granularity than that, so I'm leaving this as a separate ticket apart from 1215520.

Sam Bull (dreamsorcerer) wrote :

This had nothing to do with the charging icon, they had peculiar values as I mentioned in the other comment at the time this bug was registered. I think the problem was the old 10/30/60 icons linked, where 99% charge would be the 60% icon, which is really inaccurate.

The current implementation works nicely, where 90-100% is a full bar, 70-90% is a 80% bar etc.

This is almost fixed, except that I'm finding the icon doesn't change reliably below the 40% image. I currently have 18% charge, and it still displays the 40% icon, when it should be displaying the red 20% icon.

Once this displays the low battery icons reliably, then this bug is fixed.

Matthew Paul Thomas (mpt) wrote :

I don't think this is a design bug. The spec says "If it is discharging, the icon interior should be filled from left to right approximately as much as the remaining charge". <https://wiki.ubuntu.com/Power#Icons> And that's what the linked code appears to do. So if there's a case where the icon doesn't match the percentage, that's a bug in either the indicator code or the icon theme, not the design.

Changed in ubuntu-ux:
assignee: Matthew Paul Thomas (mpt) → nobody
status: New → Incomplete

Updated description to match current state of this bug, as tested on r10.

description: updated
summary: - battery icon and percentage
+ battery icon unreliable at low battery levels
Sam Bull (dreamsorcerer) wrote :

This is still an issue on r132.

affects: unity8 → indicator-power
affects: ubuntu-ux → indicator-power (Ubuntu)
Changed in indicator-power (Ubuntu):
status: Incomplete → Triaged
Changed in indicator-power:
status: Confirmed → Triaged
Charles Kerr (charlesk) wrote :

Confirmed, I'm seeing this on phablet too.

The problem is that the icon being generated when charging at ~18% looks for:
1. battery-low-charging-symbolic
2. gpm-battery-020-charging
3. battery-020-charging

if battery-low-charging-symbolic were moved to the end of the list, the more granular battery-XXX-charging icons would take precedence.

I agree with Sam, this ticket isn't fixed until this behavior gets fixed.

Matthew Paul Thomas (mpt) wrote :

Duplicate bug 1317848 was triaged as Critical.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.10.20140611-0ubuntu1

---------------
indicator-power (12.10.6+14.10.20140611-0ubuntu1) utopic; urgency=low

  [ Charles Kerr ]
  * Prefer the 'battery-XXX-charging' (eg, 'battery-020-charging') icons
    over the 'battery-low-charging' ones because the former are more
    precise and likely closer to the actual battery level. (LP:
    #1186181)

  [ Iain Lane ]
  * Remove the brightness slider from the phone menu. (LP: #1289470)
 -- Ubuntu daily release <email address hidden> Wed, 11 Jun 2014 17:21:30 +0000

Changed in indicator-power (Ubuntu):
status: Triaged → Fix Released
Sam Bull (dreamsorcerer) wrote :

Ran my battery down to 7% yesterday, still showing the 40% icon. So, the problem is still present in r133. So, unless the fix hasn't landed yet, this hasn't been fixed.

Charles Kerr (charlesk) on 2014-07-23
Changed in indicator-power (Ubuntu):
status: Fix Released → Triaged
Charles Kerr (charlesk) wrote :

Yes, I'm seeing this too. There's a second problem, unrelated to https://code.launchpad.net/~charlesk/indicator-power/1p-1186181-prefer-battery-charging-XXX-icons, that shows up only for discharging batteries at a low percentage:

This goes back to bug #743823, which is about not showing the 'critical red' icon -- regardless of the battery percentage level -- if more than 30 minutes is left on the battery. 0% and 20% both show critical red, so the code's workaround is to bump the icon up to the 40% level.

This works less well now that the phone profile of indicator-power shows the battery charge percentage in the menu, and the desktop profile supports showing the percentage side-by-side with the battery icon.

I see two solutions to this:

1. Remove the "use the 40% icon" code so the icon and percentage text will roughly match. This has the benefit of being simple. It regresses on bug #743823, but I'm not sure that's such a bad thing.

2. Remove the "use the 40% icon" code but have two versions of the 0% and 20% icons -- one set showing critical red and one not -- to be used depending on time remaining. This IMO is closer to the spirit of the spec, but it's also potentially confusing to users, requires new icons, and will take a little bit of care to ensure that it doesn't break 3rd party icon sets too badly on the desktop.

Of these two, I'd lean toward option 1 because it would be the less surprising to users. However (1) maybe there are other options I'm not thinking of and (2) this question should probably go through Design, so I'm going to add design to this ticket.

Changed in indicator-power:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Medium
Charles Kerr (charlesk) wrote :

Promoting ticket to high based on bug #1338604. I'm not sure how long mpt is out; maybe another designer should look at this.

Changed in indicator-power:
importance: Medium → High
Charles Kerr (charlesk) on 2014-07-28
Changed in indicator-power:
assignee: Matthew Paul Thomas (mpt) → John Lea (johnlea)
John Lea (johnlea) on 2014-07-28
summary: - battery icon unreliable at low battery levels
+ [Indicator] battery icon unreliable at low battery levels
Changed in ubuntu-ux:
assignee: nobody → Daniela Ferrai (dferrai)
importance: Undecided → High
status: New → Triaged
Charles Kerr (charlesk) on 2014-07-28
Changed in indicator-power:
assignee: John Lea (johnlea) → Charles Kerr (charlesk)
Daniela Ferrai (dferrai) wrote :

I would agree with Matthew, it seems this is not a UX bug, rather a implementation issue. Assets and specifications have been provided (please view https://wiki.ubuntu.com/Power#Icons).

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Daniela Ferrai (dferrai) on 2014-07-28
Changed in ubuntu-ux:
assignee: Daniela Ferrai (dferrai) → Matthew Paul Thomas (mpt)
status: Fix Committed → Triaged
Daniela Ferrai (dferrai) wrote :

I potential solution we've been discussing with Nick Dedekind (deadnick) is to dynamically draw the icon so it always represents an accurate power status without having to rely on assets. I'll provide more updates in the next couple of days.

Charles Kerr (charlesk) wrote :

Okay, after follow-up from Daniela it looks like for RTM we're going with option #1 from https://bugs.launchpad.net/indicator-power/+bug/1186181/comments/12 and we can revisit this after RTM as necessary.

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in indicator-power:
status: Triaged → In Progress
Adolfo Jayme (fitojb) on 2014-07-29
Changed in indicator-power (Ubuntu):
importance: Undecided → High
Sam Bull (dreamsorcerer) wrote :

A comment on the 30 mins idea: that seems fine for a laptop with a few hours battery life, it gives enough time to finish what you're doing and shutdown the machine. But, for an always-on device like a phone, 30 mins is not enough warning to do anything if I happen to be out and about; I would expect atleast a 2 or 3 hour warning in order to have a chance of being able to charge my phone before it runs out.

tags: added: pat rtm14

I am still facing the same problem on r195.

My battery level is 2% and still showing the white icon. As you can see on attached picture.

Thomas Strehl (strehl-t) on 2014-08-22
tags: added: touch-2014-08-28
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.10.20140822-0ubuntu1

---------------
indicator-power (12.10.6+14.10.20140822-0ubuntu1) utopic; urgency=low

  [ Charles Kerr ]
  * Choose the icon that's closest to the current battery charge
    percentage (LP: #1186181)
 -- Ubuntu daily release <email address hidden> Fri, 22 Aug 2014 16:15:51 +0000

Changed in indicator-power (Ubuntu):
status: Triaged → Fix Released
Charles Kerr (charlesk) on 2014-08-25
Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Changed in indicator-power:
status: In Progress → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments