Slide out toolbar should be displayed by default on the desktop (swiping is difficult)

Reported by Jono Bacon on 2013-05-22
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Critical
Tim Peeters
Ubuntu UX
High
Vesa Rautiainen
friends-app (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
High
Tim Peeters

Bug Description

When running an Ubuntu SDK app on the desktop the toolbar needs is not visible and needs to be swiped out from the bottom of the window. This is uninituitive and gives the impression that no toolbar exists.

Desired solution:
Use hovering onEntered and onExited events on desktop to hint that there is a toolbar available.
See the prototype: lp:~vesar/+junk/hover-hint-toolbar

Also the spec updated: https://docs.google.com/a/canonical.com/document/d/1pIhxERCp355mI9SeA1M8W2vN4HVINEpEVCNx3y7ab4E/edit#

Related branches

lp:~tpeeters/ubuntu-ui-toolkit/09-desktop-toolbar
Merged into lp:ubuntu-ui-toolkit at revision 1002
PS Jenkins bot: Approve (continuous-integration) on 2014-04-03
Zsombor Egri: Approve on 2014-04-03
tags: added: desktop
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
importance: Undecided → Medium
importance: Medium → High
Changed in ubuntu-ux:
assignee: nobody → Calum Pringle (calumpringle)
Changed in ubuntu-ux:
status: New → Confirmed
John Lea (johnlea) on 2013-06-20
Changed in ubuntu-ux:
importance: Undecided → Medium
Changed in ubuntu-ux:
importance: Medium → High
status: Confirmed → In Progress
Kai Mast (kai-mast) wrote :

The same should also apply for the Tabbar at the top. No need to hide it if there is enough space on the screen.

Robert Bruce Park (robru) wrote :

I think it's critical that this bug be solved before Saucy is released.

In the version of friends-app that we released in Raring, we had hard-coded the toolbar to always be visible, but in Saucy we've dropped this hack in order to be more "mobile friendly". Except that the toolbar is infuriatingly unusable on the desktop because a) it's not discoverable and b) it's nearly impossible to grab the toolbar without accidentally resizing the window instead.

So please don't think "oh, this is some abstract problem that we can worry about later", this is a real issue that is currently crippling friends-app in Saucy and needs to be fixed ASAP.

Thanks.

Changed in ubuntu-ui-toolkit:
importance: High → Critical
Tim Peeters (tpeeters) wrote :

Bug https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1207369 is related, although that one is for touch devices.

We currently do not detect whether we are on "phone" or "desktop". The only difference is screen size. Possible future differences that make sense to detect are "touch-screen" and "keyboard/mouse attached" (and more such as gps but that is not relevant for this bug).

We need feedback from design to decide what happens with the toolbar in which case (for example, vertical resolution > 100 grid units --> always lock toolbar in opened state?).

Re-assigning to Vesa because Calum is not working with us anymore. Feel free to re-assign if someone else from design is responsible for this.

Changed in ubuntu-ux:
assignee: Calum Pringle (calumpringle) → nobody
Tim Peeters (tpeeters) wrote :

It seems like I can only assign members of teams that I am a member of, can someone from design please assign the person who will work on this? thanks.

Vesa Rautiainen (vesar) on 2013-08-21
Changed in ubuntu-ux:
assignee: nobody → Vesa Rautiainen (vesar)
Vesa Rautiainen (vesar) on 2013-08-21
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) wrote :

Vesa where are the exact specifications when the toolbar should be "locked" opened, and when we have auto-show/hide? I think there are only specs available for touch.

Changed in ubuntu-ui-toolkit:
status: Confirmed → Incomplete
Tim Peeters (tpeeters) on 2013-09-03
Changed in ubuntu-ux:
status: Fix Committed → Confirmed
Vesa Rautiainen (vesar) wrote :

Sorry for missing the description. I already added desired solution once but I guess I didn't save the bug report properly as I can see that it is still missing. The idea is to use hover events to hint about toolbar existence.

description: updated
description: updated
Vesa Rautiainen (vesar) on 2013-09-06
description: updated
Vesa Rautiainen (vesar) on 2013-09-06
Changed in ubuntu-ux:
status: Confirmed → Fix Committed
Jono Bacon (jonobacon) wrote :

From what I can tell the current solution to this bug is that the toolbar is hidden and when the mouse enters the region of where the toolbar exists a hint is displayed and the user will drag out the toolbar.

If this is the recommended approach I think we are making a mistake. I think this doesn't make sense for two reasons:

 1. Historically desktop applications show toolbars by default; it is unintuitive for a user to have to pull out a toolbar to make use of it. I understand the rationale here on the phone as we use the edges, but we don't use the edge of the desktop screen on the desktop as we are using windows.
 2. Having to pull out the toolbar everytime you need to use it is going to get rather frustrating rather quickly. It also requires a special level of mouse dexterity as the 1GU area is quite narrow to pull out the toolbar.

Can the design team provide some rationale about why we don't simply display the toolbar by default?

tags: added: sdk-app-desktop-integration
Tim Peeters (tpeeters) on 2013-10-18
Changed in ubuntu-ux:
status: Fix Committed → Confirmed
Tim Peeters (tpeeters) wrote :

What is the hardware feature that should tell us we are on desktop and have a different behavior for the toolbar? Is it screen size? lack of touch-screen? It seems straightforward to distinguish between a phone and a PC, but of course there can be (hybrid) devices that are something inbetween..

Changed in ubuntu-ui-toolkit:
assignee: nobody → Tim Peeters (tpeeters)
Kai Mast (kai-mast) wrote :

Just use screen height. As soon as there is enough space there should be no problem with displaying the toolbar.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Tim Peeters (tpeeters) wrote :

Screen height may not be the best solution. Screen height (in pixels) may be larger on a phone than on a laptop.

Tim Peeters (tpeeters) on 2013-11-07
Changed in ubuntu-ui-toolkit:
importance: Critical → High
Tim Peeters (tpeeters) on 2013-11-11
tags: added: toolbar
Robert Bruce Park (robru) wrote :

C'mon designers, haven't you read your Fitt's law? Edge-swiping on a fullscreen mobile app is great, because the "edge" target is effectively infinite in size, so it's an easy swipe. Swiping up on a windowed desktop application is infuriatingly impossible, because the 1px target is *tiny*.

Yes, obviously there are a range of devices and the concept of "desktop" is nebulous at best, but it should not be difficult to come up with a reasonable set of heuristics for when it makes sense to lock the toolbar open. Something like "Only autohide the toolbar when the app is running fullscreen and there is no mouse connected"

As far as I'm concerned, the presence of touch input is irrelevant; connecting a mouse should lock open the toolbars. But even without a mouse, Fitt's law clearly indicates that a hidden toolbar that is not at the extreme edge of the display is a bad idea.

Changed in ubuntu-ui-toolkit:
status: Incomplete → Triaged
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Triaged
Changed in friends-app (Ubuntu):
status: New → Won't Fix
Jose Luis Tirado (txelu70) wrote :

In my opinion just including a menu with an option to reveal the toolbar would make a difference. Not the best option, for sure, but I least something that any desktop user could expect. The application is completely useless for a desktop environment as it is, having no menu, no toolbar and not being integrated with the messaging indicator (even the old gwibber allowed to post messages from there). Even having to pull the upper panel down to refresh is bizzarre for a desktop.

Jouni Helminen (jounihelminen) wrote :

Have you guys tried Vesa's prototype linked in the bug description? It doesn't use dragging, instead a hint of the toolbar is showed on hovering mouse at the bottom of the screen, and clicking it shows the toolbar. Give it a go.

Another option is to show toolbars all the time, if a pointer device is attached - do we have an API for detecting when a pointer device is attached? I think we need such an API for other components as well do adjust between touch/desktop, not just the toolbar

Robert Bruce Park (robru) wrote :

Jouni, how do I install or test it? I don't see any instructions for building it. There's no debian/ directory so it's not a package I can install.

In any case, a visual cue that a toolbar is there is a nice first step, but I think it's only a half-measure. Having to click to reveal a toolbar is an annoying extra click when you have dual 1080p screens in front of you.

I firmly maintain that the toolkit should simply say "mouse present == toolbar visibility locked". Plug in a mouse on your phone, and all the toolbars pop out permanently. laptops have trackpads, so toolbars stay visible. End of story.

Tim Peeters (tpeeters) wrote :

Robert, your suggestion sounds good to me (at least until we figure out a better way to do it).
I reported this bug https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1256124 which needs to be fixed first.

Vesa Rautiainen (vesar) wrote :

Sorry the willow team is a private repo. I pushed the prototype also here: lp:~vesar/+junk/hover-hint-toolbar
To run it you need have Qt installed on you machine.
So branch it cd to it and run with command:
qmlscene testToolbarConcept.qml

For convenience I also uploaded a screen cast of the prototype.
https://docs.google.com/a/canonical.com/file/d/0B8eY_FZZ1z7IOEdUWEZQUUFWTmM/view

description: updated
Changed in ubuntu-ux:
status: Confirmed → Fix Committed

I tested the branch; hover+drag seems to work but hover+click doesn't
open the toolbar.

At any rate, I still believe that toolbars should be locked open while
a mouse is present.

Kai Mast (kai-mast) wrote :

I am eagerly waiting for a fix of this bug too.

However, I wonder if the toolbar is even needed on the desktop. Shouldn't actions be available through the global menu?

tags: added: desktop-touch
removed: desktop

I think, the original problem is that the button bar is not visible. I took 1 year to find where is it reporting a bug here. I thinked that was a bug!

Changed in ubuntu-ui-toolkit:
milestone: none → february-2014
Bill Filler (bfiller) on 2014-03-10
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
assignee: nobody → Tim Peeters (tpeeters)
Changed in ubuntu-ui-toolkit:
milestone: february-2014 → march-2014
Zsombor Egri (zsombi) on 2014-03-28
Changed in ubuntu-ui-toolkit:
importance: High → Critical
Zsombor Egri (zsombi) wrote :

Toolbar could be revealed when the mouse hovers over it. As we discussed, this would be enough for the moment till we have toolbar and we get all the tools migrated into the header.

Zsombor Egri (zsombi) on 2014-03-31
Changed in ubuntu-ui-toolkit:
milestone: march-2014 → april-2014
Tim Peeters (tpeeters) on 2014-04-01
Changed in ubuntu-ui-toolkit:
status: Triaged → In Progress
Tim Peeters (tpeeters) on 2014-04-01
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20140408.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20140408.1-0ubuntu1) trusty; urgency=low

  [ Zoltán Balogh ]
  * Change Ubuntu API links in the docs (LP: #1303535) (LP: #1303535)

  [ Leo Arias ]
  * Improve the check of tab selection mode by moving to it first.
  * On the autopilot helpers to click a toolbar button, check that the
    toolbar is opened first. (LP: #1302706)

  [ tpeeters ]
  * Improve toolbar handling on desktop by opening it on mouse hover.
    (LP: #1182734)
  * If a Page is inside a Tab and has no title set, get it automatically
    from the Tab. (LP: #1289695)
 -- Ubuntu daily release <email address hidden> Tue, 08 Apr 2014 14:47:06 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Tim Peeters (tpeeters) on 2014-04-10
Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers