There is no ListItem implementing the expansion behaviour

Reported by Joshua Gleitze on 2013-04-15
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
High
Michael Zanetti
Ubuntu UX
High
Katie Taylor
Unity 8
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

The expansion pattern is described here: http://design.ubuntu.com/apps/building-blocks/expansion . It is a great pattern that could be useful in many cases. Nevertheless, there is no item that somehow implements it. First of all it is confusing to find documentation about something that isn't there. Furthermore, if everybody implements the extension pattern on his own, this will lead to inconsensity.

Related branches

lp:~nicolas-doffay/ubuntu-ui-toolkit/list-item-option-selector
Merged into lp:ubuntu-ui-toolkit at revision 735
PS Jenkins bot: Approve (continuous-integration) on 2013-09-02
Zoltan Balogh: Approve on 2013-09-02
lp:~mzanetti/ubuntu-ui-toolkit/expanding-listitem
Rejected for merging into lp:ubuntu-ui-toolkit
Michael Zanetti (community): Disapprove on 2014-02-19
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-02-13
Zsombor Egri: Needs Fixing on 2014-02-13
Michał Sawicz: Needs Fixing on 2013-11-25
Florian Boucault: Pending requested 2013-11-29
lp:~mzanetti/ubuntu-ui-toolkit/expandable-and-column
Merged into lp:ubuntu-ui-toolkit at revision 956
Zsombor Egri: Approve on 2014-02-26
PS Jenkins bot: Approve (continuous-integration) on 2014-02-26
lp:~mzanetti/ubuntu-ui-toolkit/ubuntulistview
Merged into lp:ubuntu-ui-toolkit at revision 956
Zsombor Egri: Approve on 2014-02-26
PS Jenkins bot: Approve (continuous-integration) on 2014-02-26
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
summary: - There is no ListItem implementing the extension behaviour
+ There is no ListItem implementing the expansion behaviour
Changed in ubuntu-ui-toolkit:
importance: Undecided → High
Calum Pringle (calumpringle) wrote :

Agreed. Pattern requires consistent design and an SDK component.

Changed in ubuntu-ux:
assignee: nobody → Calum Pringle (calumpringle)
status: New → Confirmed
importance: Undecided → High
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision 735, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130903.3-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130903.3-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Reverse cherrypicking rev734.

  [ Zsombor Egri ]
  * Branch 734 removed, causing Unity test failures.

  [ Nicolas d'Offay ]
  * Added ItemSelector. Extend OptionSelector and fixed various bugs.
    Added tests for both OptionSelector and ItemSelector. (LP: #1169258,
    #1218250, #1218247)

  [ tpeeters ]
  * New toolbar reveal/hide behavior, as specified by design. (LP:
    #1207369)

  [ <email address hidden> ]
  * This MP contains some fixes to autopilot test cases. Two test cases
    are commented for now as they were giving inconsistent results on
    phone. .

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 738
 -- Ubuntu daily release <email address hidden> Tue, 03 Sep 2013 11:46:19 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
Daniel Holm (danielholm) wrote :

I dont think this is fixed yet. Where is the expanded ListItem? It's not in the ui-toolkit-gallery.
And OptionSelector isn't it. I got 0.1.46+13.10.20130903.4 installed.

John Lea (johnlea) on 2013-09-09
Changed in ubuntu-ux:
assignee: Calum Pringle (calumpringle) → Katie Taylor (katie-t)
Sam Bull (dreamsorcerer) on 2013-09-12
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Confirmed
kevin gunn (kgunn72) wrote :

adding to unity8 as well...since work on dash option selector is actually feeding this for the toolkit

Changed in unity8:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
importance: Undecided → High
status: New → Confirmed
Michał Sawicz (saviq) wrote :

We're still missing a generic expandable component and a corresponding container that would ensure consistent behaviour of expandables (scrolling into view etc.).

Roman Shchekin (mrqtros) wrote :

I want to see expandable item too.
There are a lot of items for selecting, but no for expanding.

We need it for our RSS Reader (Shorts).

My concern is if the parent object isn't a ListView or flickable? We'd need different logic to handle the scrolling then.

Michał Sawicz (saviq) wrote :

If there's no Flickable (which ListView inherits, btw), there's no scrolling anyway.

The ExpandingContainer would just have to be a Flickable or a ListView, is all.

I disagree. I think the expansion item should only provide the functionality of expansion. Any Flickables in or outside the expansion block should be left to the programmer. It's not the job of the item to make sure its content is visible. So in my opinion, we don't have to worry about any scrolling logic.

Michał Sawicz (saviq) wrote :

We'll have to agree to disagree. If the developers will need to cater for such behaviors themselves, it will just never happen, or be inconsistent at best. The expansion pattern is a very visible pattern in Ubuntu Touch, and needs to be consistent and predictable.

If the developer will want to, they can still use the expanding component outside of the container... but then it's just a one-line Behavior on height { } at that point.

All the expanding components within the SDK, though, need to behave consistently and cater for good user experience - without the need for users to have to hunt for the UI element they wanted to interact with.

Well, you have a point. Maybe it would be best to implement a default behaviour, as you say. Making this behaviour overwritable to the programmer would then increase (re-)usability, in my opinion.

Sam Bull (dreamsorcerer) wrote :

Is there any progress on this? I think a lot of developers are waiting on this. We can't make much more progress on our bitcoin-app project until this is completed.

Michał Sawicz (saviq) wrote :
Changed in ubuntu-ui-toolkit:
assignee: Nicolas d'Offay (nicolas-doffay) → nobody
Changed in unity8:
assignee: Nicolas d'Offay (nicolas-doffay) → nobody
Michał Sawicz (saviq) on 2013-12-17
Changed in ubuntu-ui-toolkit:
assignee: nobody → Michael Zanetti (mzanetti)
Michał Sawicz (saviq) on 2013-12-23
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Changed in unity8:
status: Confirmed → Invalid
importance: High → Undecided
Sam Bull (dreamsorcerer) wrote :

How's this progressing? It looked like it was almost ready to merge a month ago, and seems to have gone silent since.

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Released
Changed in ubuntu-ui-toolkit:
milestone: none → february-2014
Sam Bull (dreamsorcerer) wrote :

Is this available yet? I don't seem to be able to use it after updating the PPA, and don't see it in the API. Are we waiting for a new UITK release?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers