[clock app] Timer does not inform user if there are no presets

Reported by Nekhelesh Ramananthan on 2013-04-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Low
Nekhelesh Ramananthan
Ubuntu UX
Undecided
Lina Pio

Bug Description

The app clock journey provided by the design team provide the design shown in in the link 1 below for viewing timer presets. However, there could a scenario where the user deletes all the existing timers. In that situation, the user is presented with a blank screen as shown in Link 2.

It would be better if there is a message like "No presets set. Click Add Preset to create one" or something similar to inform the user.

Link 1: http://design.canonical.com/wp-content/uploads/clock_timer_from_preset-1024x466.png
Link 2: http://ubuntuone.com/22OYggGCxgTj2d1rKz7zQC

------
Solution: if there are no presets set, the timer clock face is the only thing the user sees. If there are presets, the first thing the user sees is the list of other timers already saved as presets.

Related branches

lp:~nik90/ubuntu-clock-app/new-preset-designs
Merged into lp:ubuntu-clock-app at revision 179
Ubuntu Phone Apps Jenkins Bot: Approve (continuous-integration) on 2013-09-03
Nicholas Skaggs: Approve on 2013-09-03
tags: added: timer
Changed in ubuntu-clock-app:
milestone: coreapps-13.10-month-1 → coreapps-13.10-month-2
Changed in ubuntu-clock-app:
milestone: coreapps-13.10-month-2 → coreapps-13.10-month-3
maxicastro (maxicastro) on 2013-07-06
Changed in ubuntu-clock-app:
assignee: nobody → maxicastro (maxicastro)
Nekhelesh Ramananthan (nik90) wrote :

@maxicastro, Nice to see you take iniative to help fix this bug. However we haven't received any information from the design team regarding the implementation. So I am afraid we need to wait on this before starting to work on it. I have sent a mail to the design team regarding this. Should expect a reply within the next 3-4 days.

maxicastro (maxicastro) wrote :

@nik90, Oh ! Ok! So we expect the design.
I assigned it because I did not find difficult and was not assigned to anyone. But if you consider deallocate it, no problem.
Apologies. I'll be watching.

Nekhelesh Ramananthan (nik90) wrote :

@maxicastro, no worries. I'll let this be allocated to you. I will forward the reply that I get from the design team regarding this bug. You can then start working on it :-). Meanwhile if you are interested you could also take a look at the autopilot bugs if you want.

Changed in ubuntu-clock-app:
milestone: coreapps-13.10-month-3 → usable-state
John Lea (johnlea) on 2013-07-17
Changed in ubuntu-ux:
assignee: nobody → Lina Pio (linapio)
Lina Pio (linapio) on 2013-08-13
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
Changed in ubuntu-clock-app:
status: Confirmed → In Progress
assignee: maxicastro (maxicastro) → Nekhelesh Ramananthan (nik90)

Fix committed into lp:ubuntu-clock-app at revision 179, scheduled for release in ubuntu-clock-app, milestone usable-state

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers