[clock app] Stopwatch needs to show 1/10th of a second in the label for better accuracy

Reported by Nekhelesh Ramananthan on 2013-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Medium
Alessandro Pozzi
Ubuntu UX
High
Mika Meskanen

Bug Description

Currently the stopwatch timer uses the hh:mm:ss format to diplay the stopwatch time. However, in reality a stopwatch is used to measure lap times in accuracies of 1/100th of a second. Hence it is important to include that in the stopwatch timer.

Get confirmation from design team before implementing it.

By default it should show mm:ss:ms where ms is the 1/100th of a second. However when the stopwatch goes over 59 minutes, then the format should dynamically change to hh:mm:ss:ms where hh is the hour.

--------------------------------------------------------------------------------------

Due to limitation in QML, it has been decided to show 1/10 of second rather than 1/100th of a second in the stopwatch label. This change has been approved by Mika Meskanen. Please read https://bugs.launchpad.net/ubuntu-clock-app/+bug/1163855/comments/6 for more information.

Changed in ubuntu-clock-app:
status: New → Confirmed
tags: added: needs-design
Changed in ubuntu-clock-app:
importance: Undecided → Low
milestone: none → alpha-1
summary: - Stopwatch needs to show microseconds in the label for better accuracy
+ [clock app] Stopwatch needs to show microseconds in the label for better
+ accuracy
Changed in ubuntu-ux:
assignee: nobody → Calum Pringle (calumpringle)
assignee: Calum Pringle (calumpringle) → Mika Meskanen (mika)

I think microseconds are too accurate. This is a manually operated stopwatch. For example, in athletics hand held times are returned to 1/10 second because of human error. E.g. http://www.seaoa.co.uk/duties/timekeeper/102-timekeeping-primary-duties.html

Out of convention, we can stick to 1/100 seconds, because that's what wristwatches provide and people are used to it.

Changed in ubuntu-ux:
status: New → Won't Fix
Mika Meskanen (mika) wrote :

As a reminder, here's the original schematic
http://ubuntuone.com/4gJPTZOpphfMF4zXnQG0aP

Nekhelesh Ramananthan (nik90) wrote :

@Mika, I think I mistakingly typed microseconds. In the orginal schematic picture I see you used the format mm:ss:ms (where ms is 1/100 sec). However in the current stopwatch implementation it is hh:mm:ss. So we are missing the millisecond I suppose. I can fix that in our implementation.

summary: - [clock app] Stopwatch needs to show microseconds in the label for better
- accuracy
+ [clock app] Stopwatch needs to show 1/100th of a second in the label for
+ better accuracy
description: updated

I have updated the bug report. Can you confirm if this is approved?

Mika Meskanen (mika) on 2013-04-16
Changed in ubuntu-ux:
status: Won't Fix → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
Changed in ubuntu-clock-app:
assignee: nobody → Alessandro Pozzi (signor-hyde)
description: updated
Changed in ubuntu-clock-app:
importance: Low → Medium
Mika Meskanen (mika) wrote :

Hi @Nekhelesh, ok understood. It's totally valid bug now, thank you!

Changed in ubuntu-clock-app:
status: Confirmed → In Progress
Nekhelesh Ramananthan (nik90) wrote :

We have a small issue with the implementation. Currently the stopwatch timer runs every 100 miliseconds (1/10th of a second). In order for it to display 1/100th of a second, the stopwatch timer must run every 10 milliseconds. However the QML Timer has limitations for the minimum time which is 16 ms mentioned at http://harmattan-dev.nokia.com/docs/library/html/qt4/qml-timer.html. Hence it would not be possible to display 1/100th of a second (called centisecond) but we can only display 1/10th of a second (called decisecond).

Is this ok? Or should we scrap it altogether and just diplay hh:mm:ss? Need design decision on this.

I think that the best solutions is hh:mm:ss.ms and mm:ss:ms when hh is = 0
for exemple 01:22.5 I will use only 1 number for ms is too nice
bye

2013/4/17 Nekhelesh Ramananthan <email address hidden>

> We have a small issue with the implementation. Currently the stopwatch
> timer runs every 100 miliseconds (1/10th of a second). In order for it
> to display 1/100th of a second, the stopwatch timer must run every 10
> milliseconds. However the QML Timer has limitations for the minimum time
> which is 16 ms mentioned at http://harmattan-
> dev.nokia.com/docs/library/html/qt4/qml-timer.html. Hence it would not
> be possible to display 1/100th of a second (called centisecond) but we
> can only display 1/10th of a second (called decisecond).
>
> Is this ok? Or should we scrap it altogether and just diplay hh:mm:ss?
> Need design decision on this.
>
> --
> You received this bug notification because you are a bug assignee.
> Matching subscriptions: Alessandro Pozzi, Alessandro Pozzi
> https://bugs.launchpad.net/bugs/1163855
>
> Title:
> [clock app] Stopwatch needs to show 1/100th of a second in the label
> for better accuracy
>
> Status in Clock application for Ubuntu devices:
> In Progress
> Status in Ubuntu UX bugs:
> Triaged
>
> Bug description:
> Currently the stopwatch timer uses the hh:mm:ss format to diplay the
> stopwatch time. However, in reality a stopwatch is used to measure lap
> times in accuracies of 1/100th of a second. Hence it is important to
> include that in the stopwatch timer.
>
> Get confirmation from design team before implementing it.
>
> By default it should show mm:ss:ms where ms is the 1/100th of a
> second. However when the stopwatch goes over 59 minutes, then the
> format should dynamically change to hh:mm:ss:ms where hh is the hour.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-clock-app/+bug/1163855/+subscriptions
>

Alessandros solutions sounds good! Attached an updated wireframe based on his suggestion.

summary: - [clock app] Stopwatch needs to show 1/100th of a second in the label for
+ [clock app] Stopwatch needs to show 1/10th of a second in the label for
better accuracy
description: updated

Fix committed into lp:ubuntu-clock-app at revision 37, scheduled for release in ubuntu-clock-app, milestone alpha-1

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-08-08
Changed in ubuntu-ux:
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers