[clock app] No easy way to set timer for an hour or more

Reported by Nekhelesh Ramananthan on 2013-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Medium
Nekhelesh Ramananthan
Ubuntu UX
High
Mika Meskanen

Bug Description

The current design interface for the Timer inhibits easy setting of timers for 01:00, 02:00, 03:00 and later since the +,- buttons only increment by a minute. This makes it painful to set a timer for hours. Despite the common usage case of timers to be limited to minutes, it is important we provide the functionality to the user to set hours in an easier fashion.

Related branches

lp:~nik90/ubuntu-clock-app/timer-touch-input
Merged into lp:ubuntu-clock-app at revision 24
Alessandro Pozzi (community): Approve on 2013-04-09
Ubuntu Phone Apps Jenkins Bot: Approve (continuous-integration) on 2013-04-09
Ubuntu Clock Developers: Pending requested 2013-04-06
Changed in ubuntu-clock-app:
status: New → Confirmed
tags: added: needs-design

I've try with long press on plus button if you ok i restore this options to
up hours

2013/4/3 Nekhelesh Ramananthan <email address hidden>

> Public bug reported:
>
> The current design interface for the Timer inhibits easy setting of
> timers for 01:00, 02:00, 03:00 and later since the +,- buttons only
> increment by a minute. This makes it painful to set a timer for hours.
> Despite the common usage case of timers to be limited to minutes, it is
> important we provide the functionality to the user to set hours in an
> easier fashion.
>
> ** Affects: ubuntu-clock-app
> Importance: Undecided
> Status: Confirmed
>
>
> ** Tags: needs-design
>
> ** Changed in: ubuntu-clock-app
> Status: New => Confirmed
>
> ** Tags added: needs-design
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> Clock App.
> Matching subscriptions: Alessandro Pozzi, Alessandro Pozzi
> https://bugs.launchpad.net/bugs/1163854
>
> Title:
> No easy way to set timer for an hour or more
>
> Status in Clock application for Ubuntu devices:
> Confirmed
>
> Bug description:
> The current design interface for the Timer inhibits easy setting of
> timers for 01:00, 02:00, 03:00 and later since the +,- buttons only
> increment by a minute. This makes it painful to set a timer for hours.
> Despite the common usage case of timers to be limited to minutes, it
> is important we provide the functionality to the user to set hours in
> an easier fashion.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-clock-app/+bug/1163854/+subscriptions
>

Alessandro, I talked to the design team last thursday. They need to modify the design to make it easier to set hours. Changing the +,- buttons to hours won't solve the problem since then it wouldn't be possible to change the minutes anymore. So we will have to wait for new designs until then.

my idea is: if you click plus or minus you up or down minutes. if you press
plus or minus for more second you increment hours.

2013/4/3 Nekhelesh Ramananthan <email address hidden>

> Alessandro, I talked to the design team last thursday. They need to
> modify the design to make it easier to set hours. Changing the +,-
> buttons to hours won't solve the problem since then it wouldn't be
> possible to change the minutes anymore. So we will have to wait for new
> designs until then.
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> Touch Core Apps.
> Matching subscriptions: Alessandro Pozzi, Alessandro Pozzi
> https://bugs.launchpad.net/bugs/1163854
>
> Title:
> No easy way to set timer for an hour or more
>
> Status in Clock application for Ubuntu devices:
> Confirmed
>
> Bug description:
> The current design interface for the Timer inhibits easy setting of
> timers for 01:00, 02:00, 03:00 and later since the +,- buttons only
> increment by a minute. This makes it painful to set a timer for hours.
> Despite the common usage case of timers to be limited to minutes, it
> is important we provide the functionality to the user to set hours in
> an easier fashion.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-clock-app/+bug/1163854/+subscriptions
>

@Design, Here is an idea of a timer made by another community member Michal for his application Zeegaree at http://www.youtube.com/watch?feature=player_embedded&v=OooVr5zlfwQ#t=28s

Calum Pringle (calumpringle) wrote :

So we've spent some time thinking about the timer functionality and inspired by Michal (thanks for the link Nekhelesh) we are proposing to remove the "+" and "-" entirely, and focus on the interaction with the timer's "face".

Attached is a series of wireframes for adjusting minutes and seconds for your timer; also for moving from minutes to hours.

Following last weeks conversation, to clarify, in the first instance the digital representation of time is MM : SS however upon full rotation beyond 59 mins, (H)H : MM : SS

To adjust seconds, tap on SS to change the time being manipulated by the timers face from minutes to seconds. Tap on MM again to change back to manipulating minutes for the timer. (The scale remains the same around the face at 0-60)

Calum Pringle (calumpringle) wrote :

And wireframe for what happens upon full rotation beyond 59 mins, (H)H : MM : SS

Ok It's beautiful but there is a way to fix mainview's moviment
(left-right) when I change hours and minutes?

2013/4/4 Calum Pringle <email address hidden>

> And wireframe for what happens upon full rotation beyond 59 mins, (H)H :
> MM : SS
>
>
> ** Attachment added: "Minutes to hours"
>
> https://bugs.launchpad.net/ubuntu-clock-app/+bug/1163854/+attachment/3620491/+files/ChangingHour.png
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> Touch Core Apps.
> Matching subscriptions: Alessandro Pozzi, Alessandro Pozzi
> https://bugs.launchpad.net/bugs/1163854
>
> Title:
> No easy way to set timer for an hour or more
>
> Status in Clock application for Ubuntu devices:
> Confirmed
>
> Bug description:
> The current design interface for the Timer inhibits easy setting of
> timers for 01:00, 02:00, 03:00 and later since the +,- buttons only
> increment by a minute. This makes it painful to set a timer for hours.
> Despite the common usage case of timers to be limited to minutes, it
> is important we provide the functionality to the user to set hours in
> an easier fashion.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-clock-app/+bug/1163854/+subscriptions
>

Alessandro, I am working on it at the moment and I think I have fixed that one. I will upload my branch soon.

Change by dragging would be painful... If I want 1 minute I need to rotate the minute hand exactly 6 degrees, which would be very hard to achieve in a small screen.

Changed in ubuntu-clock-app:
milestone: none → alpha-1
importance: Undecided → Medium
status: Confirmed → Triaged

@Nekhelesh. I see your branch it's very good. I try it's very easy to set
time, i find an error in TimerScript.js in line 7 there is * 60, the
correct is * 3600

2013/4/5 Nekhelesh Ramananthan <email address hidden>

> ** Changed in: ubuntu-clock-app
> Milestone: None => alpha-1
>
> ** Changed in: ubuntu-clock-app
> Importance: Undecided => Medium
>
> ** Changed in: ubuntu-clock-app
> Status: Confirmed => Triaged
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> Touch Core Apps.
> Matching subscriptions: Alessandro Pozzi, Alessandro Pozzi
> https://bugs.launchpad.net/bugs/1163854
>
> Title:
> No easy way to set timer for an hour or more
>
> Status in Clock application for Ubuntu devices:
> Triaged
>
> Bug description:
> The current design interface for the Timer inhibits easy setting of
> timers for 01:00, 02:00, 03:00 and later since the +,- buttons only
> increment by a minute. This makes it painful to set a timer for hours.
> Despite the common usage case of timers to be limited to minutes, it
> is important we provide the functionality to the user to set hours in
> an easier fashion.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-clock-app/+bug/1163854/+subscriptions
>

Changed in ubuntu-clock-app:
assignee: nobody → Nekhelesh Ramananthan (nik90)
status: Triaged → In Progress
summary: - No easy way to set timer for an hour or more
+ [clock app] No easy way to set timer for an hour or more
Calum Pringle (calumpringle) wrote :

Hey @Marco you're right we've been playing a bit with this, I think for enjoyment and ease of use it'd be much easier to have the timer focussed by default on editing the seconds. So you spin round and round and round quickly for three minutes, rather than pinch it a little to get there!

Summary - timer focus is on seconds by default, user can change focus to minutes by tapping on minutes as per wireframe

Fix committed into lp:ubuntu-clock-app at revision None, scheduled for release in ubuntu-clock-app, milestone alpha-1

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Changed in ubuntu-ux:
assignee: nobody → Calum Pringle (calumpringle)
importance: Undecided → High
status: New → Triaged
assignee: Calum Pringle (calumpringle) → Mika Meskanen (mika)
tags: added: timer
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-08-08
Changed in ubuntu-ux:
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers