[Calculator app] [Visual design] Button padding/spacing inconsistent

Reported by Alan Pope ㋛ on 2013-03-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Calculator App
Medium
Dalius
Ubuntu UX
Medium
Christina Li

Bug Description

The button spacing in qmlscene on the desktop is fine, with the padding between C, 7, 4, 1, 0 and the left edge, and X, -, + and = and the right edge being fine. However on the mobile device the padding is no longer there, and the buttons are hard up against the edge of the device screen. The buttons should line up in the same way on device as in qmlscene on the desktop.

Are we using grid-units to place the buttons correctly?

Related branches

Dalius (dalius-sandbox) wrote :

We are using grid units correctly. However we might have made wrong assumption about device size.

Dalius (dalius-sandbox) wrote :

If possible please give:

1) device resolution;

2) grid unit size;

3) screenshot;

Changed in ubuntu-calculator-app:
status: New → Incomplete
importance: Undecided → Medium
Alan Pope ㋛ (popey) wrote :

Will do. Saw this over a google hangout with the design guys. Will try and get a screenshot on my own device. Thanks.

Alan Pope ㋛ (popey) wrote :

Screenshot from a nexus 7, 1280x800. Seems the issue goes the other way here. on the 4" phone there is not enough space between buttons and the edge, with the 7" tablet there's too much.

Dalius (dalius-sandbox) on 2013-03-22
Changed in ubuntu-calculator-app:
assignee: nobody → Dalius Dobravolskas (dalius-sandbox)
milestone: none → alpha-1
status: Incomplete → Confirmed
Dalius (dalius-sandbox) wrote :

The problem is simple. Our development grid is 50x75. Nexus 7 grid size is: 57x73 (grid's unit size 14 pixels).

I have tried enforcing grid's size to 50 units. Alan, could you test it on Nexus 7 and share how it looks like:
https://code.launchpad.net/~dalius-sandbox/ubuntu-calculator-app/grid-issue

Alternatively we should talk with design team about this one. There are reasons why grid's size is different on different devices and it might be undesired to have oversized calculator on big tablet :-)

Dalius (dalius-sandbox) on 2013-03-22
Changed in ubuntu-calculator-app:
status: Confirmed → In Progress
Arnaud (nono68200) wrote :

Here is a screenshot of the bug (on the last daily build).

Dalius (dalius-sandbox) wrote :

Experimental fix pushed to main branch. Please let me know how it works on your device.

Arnaud (nono68200) wrote :

No, still bug on my GNexus. :/

Dalius (dalius-sandbox) wrote :

Arnaud, maybe fix is not in build yet as I have pushed fix only today?

Arnaud (nono68200) wrote :

Yeah but I downloaded last bzr branche and push it on my Galaxy Nexus, and nothing news... Except that tabs are no more showed. Thus a bug which is corrected. But buttons too large still exists...

Dalius (dalius-sandbox) wrote :

Arnaud, thanks for info. I will try different approach then.

Fix committed into lp:ubuntu-calculator-app at revision 46, scheduled for release in ubuntu-calculator-app, milestone alpha-1

Changed in ubuntu-calculator-app:
status: In Progress → Fix Committed
Changed in ubuntu-ux:
status: New → In Progress
importance: Undecided → High
importance: High → Medium
summary: - Button padding/spacing inconsistent
+ [Calculator app] Button padding/spacing inconsistent
summary: - [Calculator app] Button padding/spacing inconsistent
+ [Calculator app] [Visual design] Button padding/spacing inconsistent
Changed in ubuntu-ux:
assignee: nobody → Christina Li (christina-li)
Alan Pope ㋛ (popey) wrote :

Much better.. See attached.

Dalius (dalius-sandbox) on 2013-05-30
Changed in ubuntu-calculator-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: In Progress → Triaged
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers