[Calculator app] Swipe up should tear off the results strip

Reported by Alan Pope ㋛ on 2013-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Calculator App
Medium
Dalius
Ubuntu UX
High
Christina Li

Bug Description

Currently pressing "C" initiates the "tear off" of the results strip, bug 1156510 filed for that. The tear-off should be initiated via swiping the 'paper' results roll upwards.

Dalius (dalius-sandbox) wrote :

The only problems with this:

a) that's unpredictable. We will need to add help to calculator :-)

b) that's inconsistent. Currently history + numpad is single ListView: if you have many items in history you can swipe up and down to see what happens and how ListView works. Now it we will remove numpad from ListView (what's fixing of this bug requires) then we will need to implement custom behaviour here for scrolling that will look ugly most probably.

Dalius (dalius-sandbox) wrote :

I have tried and failed following approach:
1. Get initial contentY. I have managed to get that only under certain actions. I don't have complete solution.
2. Now when I have contentY I tried to reposition numpad (or ListView's header - our ListView is from bottom to top). However it looks like that's not working (nothing unexpected).

Therefore alternative approach is to move numpad (header) outside of ListView but I suspect that we will have problem with history scrolling. As we will need to resize ListView's size during scroll that most probably will not work as we would like to.

At the moment I tend towards: impossible to implement.

Michael Hall (mhall119) wrote :

I've attached a branch (lp:~mhall119/ubuntu-calculator-app/tear-off-formula ) that implements the tear-off on scrolling the formula view up past the bottom.

What doesn't work is moving the numberpad down when you scroll the formula view down.

Dalius (dalius-sandbox) wrote :

Michael, thanks for trying second approach up to some degree. Moving numberpad down is what is very important actually.

Anyway thanks for writing code - that will save some time for me :-)

Dalius (dalius-sandbox) on 2013-03-21
Changed in ubuntu-calculator-app:
assignee: nobody → Dalius Dobravolskas (dalius-sandbox)
status: New → In Progress
importance: Undecided → Medium
milestone: none → alpha-1

Fix committed into lp:ubuntu-calculator-app at revision 37, scheduled for release in ubuntu-calculator-app, milestone alpha-1

Changed in ubuntu-calculator-app:
status: In Progress → Fix Committed
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Christina Li (christina-li)
summary: - Swipe up should tear off the results strip
+ [Calculator app] Swipe up should tear off the results strip
Dalius (dalius-sandbox) on 2013-05-30
Changed in ubuntu-calculator-app:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-08-08
Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers