[SIDESTAGE] can't dismiss the sidestage through grab when only sidestage app is running

Reported by Oren Horev on 2013-02-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Oren Horev
Unity 8
Medium
Michael Zanetti
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

When only sidestage is running (over the dash). The user should be able to use the grab handle to dismiss the sidestage. This should refocus the dash on the app lens (equivalent of a long left edge swipe).

Related branches

lp:~unity-team/unity8/right-edge-2
Merged into lp:unity8 at revision 798
Michał Sawicz: Approve on 2014-04-01
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-04-01
Leo Arias (community): Needs Information (autopilot code review) on 2014-03-28
Ubuntu Unity PS integration team: Pending (packaging) requested 2014-03-28
Albert Astals Cid: Pending requested 2014-03-28
Gerry Boland: Pending requested 2014-03-28
Mirco Müller: Pending requested 2014-03-28
Vesa Rautiainen: Pending requested 2014-03-28
Changed in manhattan:
importance: Critical → High
status: New → Confirmed
Andrea Cimitan (cimi) on 2013-02-27
tags: added: unity-public
Alan Pope ㋛ (popey) on 2013-05-09
information type: Private → Public
affects: manhattan → unity
Michał Sawicz (saviq) wrote :

Added ubuntu-ux for design guidance.

no longer affects: unity/phablet
Changed in unity:
assignee: Florian Boucault (fboucault) → nobody
status: Confirmed → Invalid
importance: High → Medium
importance: Medium → Undecided
Michał Sawicz (saviq) on 2013-06-26
affects: unity → unity8
Changed in unity8:
status: Invalid → Incomplete
no longer affects: unity/8.0
Michał Sawicz (saviq) on 2013-07-12
Changed in unity8:
status: Incomplete → Triaged
importance: Undecided → Medium
assignee: nobody → Unity UI Team (unity-ui-team)
no longer affects: ubuntu-ux
Oren Horev (oreneeshy) on 2013-09-27
Changed in ubuntu-ux:
assignee: nobody → Oren Horev (oreneeshy)
status: New → Fix Committed
Oren Horev (oreneeshy) on 2013-09-30
Changed in ubuntu-ux:
importance: Undecided → Critical
Changed in unity8:
assignee: Unity UI Team (unity-ui-team) → Nicolas d'Offay (nicolas-doffay)
assignee: Nicolas d'Offay (nicolas-doffay) → nobody
kevin gunn (kgunn72) on 2013-12-09
Changed in unity8 (Ubuntu):
status: New → Triaged
Changed in unity8:
assignee: nobody → Loïc Molinari (loic.molinari)
kevin gunn (kgunn72) wrote :

per design feedback - still valid

John McAleely (john.mcaleely) wrote :

tagging as mwcdemo2014 - this seems to be very easu to tumble over in the tablet demo script.

tags: added: mwcdemo2014
Alexander Sack (asac) wrote :

needs an owner/priority bump if its critical for mwc. AFAIK, loicm is not working on sidestage, so there might be better owners.

Michał Sawicz (saviq) on 2014-02-19
Changed in unity8:
assignee: Loïc Molinari (loic.molinari) → nobody
Michał Sawicz (saviq) wrote :

Are we sure this is a big issue? Bearing in mind this bug didn't have prio for a year now, and the whole side-stage / right-edge behaviour is being revisited?

Alexander Sack (asac) wrote :

I think the reason for this getting prio now is that there is something in the demo script that runs into this issue:

 "tagging as mwcdemo2014 - this seems to be very easu to tumble over in the tablet demo script."

John McAleely (john.mcaleely) wrote :

Discussed with saviq in IRC. If we get bug #1281199, we can work around this one without any difficulty:

<Saviq> john-mcaleely, the "can't dismiss side-stage when no main-stage app" issue is somewhat a corner case and I don't see how it's a big issue, could you explain a use case?
* cwayne (<email address hidden>) has joined #phablet
<john-mcaleely> Saviq, ok - just checked with victorp and I agree with you. it ties with LP#1281629
<_mup_> Bug #1281629: Launching sidestage apps from launcher prevents launcher from opening <mwcdemo2014> <unity8 (Ubuntu):New> <https://launchpad.net/bugs/1281629>
<john-mcaleely> so if we fix 1281629, & 1281199
<john-mcaleely> then 1129290 is fine to live with. And I'll get victor to change the spreadsheet
<Saviq> john-mcaleely, yeah, I thought so - once we're able to use the launcher (and so dismiss the app by swiping from left edge), we're good
<Saviq> john-mcaleely, ok thanks

NB, bug #1281629 is a dupe of #1281199

Michał Sawicz (saviq) on 2014-02-19
tags: removed: mwcdemo2014
Changed in unity8:
assignee: nobody → Albert Astals Cid (aacid)
status: Triaged → In Progress
Changed in unity8:
assignee: Albert Astals Cid (aacid) → Michael Zanetti (mzanetti)
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers