[camera] Spread / pinch should zoom in / out

Bug #1086776 reported by Calum Pringle on 2012-12-05
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Jouni Helminen
camera-app (Ubuntu)

Bug Description

Spreading two fingers apart on screen should zoom in, pinch should zoom out. Also, the zoom slider widget should reflect the extent of the zoom.


Bill Filler (bfiller) on 2012-12-11
Changed in manhattan:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Ugo Riboni (uriboni)
Bill Filler (bfiller) on 2012-12-16
Changed in manhattan:
milestone: none → demo-final
Ugo Riboni (uriboni) wrote :

Due to a bug in PinchArea in the version of Qt5 we are using, we can't have both pinch-to-zoom and dragging of the focus ring.
Calum decided that it's more important for the demo to have draggable focus ring, so this bug won't be fixed for the demo.

Changed in manhattan:
milestone: demo-final → none
information type: Proprietary → Public
Changed in manhattan:
assignee: Ugo Riboni (uriboni) → Calum Pringle (calumpringle)
affects: manhattan → ubuntu-ux
John Lea (johnlea) on 2014-04-25
Changed in ubuntu-ux:
assignee: Calum Pringle (calumpringle) → John Lea (johnlea)
assignee: John Lea (johnlea) → Jouni Helminen (jounihelminen)
Changed in ubuntu-ux:
status: Confirmed → Fix Released
Changed in camera-app:
status: New → Fix Released
Changed in camera-app (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers