[SDK] Header should be responsive for Tablet and Desktop form factors

Bug #1428757 reported by Giorgio Venturi on 2015-03-05
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Committed
Undecided
Unassigned
Ubuntu UX
High
Olga Kemmet
ubuntu-ui-toolkit (Ubuntu)
High
Tim Peeters

Bug Description

As part of our convergence path to Tablet and Desktop form factors, we will have more screen real estate and less constrained.
Therefore, we have more space to provide additional affordances.
- Optional subheader, with increased flexibility
- Max 4 slots on the right
- Capability of adding input field expanded or dropdown (not both)
- Capability of adding tabs
- Capability of having responsive labels display - once breakpoint is reached, labels are displayed

UX spec here:
https://www.dropbox.com/s/j47sua4ilof0zud/050315_Convergence%20-%20Header_gv.pdf?dl=0

VD link TBC

Related branches

affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit
Changed in ubuntu-ux:
importance: Undecided → High
assignee: nobody → Alex Milazzo (digitalalex)
description: updated
Changed in ubuntu-ux:
status: New → Triaged
Tim Peeters (tpeeters) wrote :

The link to the UX specs is broken

Zsombor Egri (zsombi) on 2015-03-30
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Tim Peeters (tpeeters)
Alex Milazzo (digitalalex) wrote :

New header UI attached

Changed in ubuntu-ui-toolkit:
assignee: nobody → Alex Milazzo (digitalalex)
Changed in ubuntu-ux:
assignee: Alex Milazzo (digitalalex) → Olga Nelyudova (olga)
assignee: Olga Nelyudova (olga) → Olga Kemmet (olga-kemmet)
Alex Milazzo (digitalalex) wrote :
Changed in ubuntu-ui-toolkit:
assignee: Alex Milazzo (digitalalex) → nobody
Changed in ubuntu-ux:
assignee: Olga Kemmet (olga-kemmet) → Alex Milazzo (digitalalex)
status: Triaged → Fix Released
Changed in ubuntu-ux:
status: Fix Released → Fix Committed
Changed in ubuntu-ux:
assignee: Alex Milazzo (digitalalex) → Olga Kemmet (olga-kemmet)
Tim Peeters (tpeeters) wrote :

UX specs were updated. Number of actions now varies from 3 to 6 depending on the width of the header. See attached MR.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (7.7 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1761+16.04.20151216.1-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1761+16.04.20151216.1-0ubuntu1) xenial; urgency=medium

  [ Zoltán Balogh ]
  * Drop dependency on qtc plugin script and wait for the shell with a local
    function.

  [ Christian Dywan ]
  * runtest.sh needs to add subdirs to the libpath. Fixes: LP: #1524710.
  * Explicit click/ touch threshold beyond handler.
  * Enter/Return/Space should trigger() Button. Fixes: LP: #1523794.
  * Only set ppmm in SwipeArea if screen has valid dpi. Fixes: LP: #1525174.

  [ Tim Peeters ]
  * Implement header slot management for convergence:
    - Adapt the number of action slots to the width of the view.
    - When a new action appears, show a quick fade-in.
    - Reverse the order of the actions in the header.
    - Update icon width to 4GU. Fixes: LP: #1428757.
  * To prevent an invalid sectionIndex, reset the value of sectionIndex to -1
    when the model of Sections is changed. Fixes: LP: #1513933.

  [ Loïc Molinari ]
  * UbuntuShape - Cleaned up includes.

  [ Albert Astals Cid ]
  * Simplify logic for emitting draggingChanged/pressedChanged
    No need for a switch that considers the possible cases, just store the
    status before and check after
    Fixes an issue in which the SwipeArea pressedChanged signal was not emitted
    if switching directly from WaitingForTouch to Recognized.
  * Fix memory leak in SwipeArea
    SwipeAreaPrivate is not deleted directly so make it part of the qobject
    hierarchy so it's auto deleted on parent destruction.

  [ Zsombor Egri ]
  * Add reset functionality to Action.shortcut property. Fixes: LP: #1518420.
  * Add contentWidth and contentHeight to Dialog so foreground can be resized.
    Fixes: LP: #1249325.
  * Fixing ListItem.selected and ListItem.selectMode bugs.
    Fixes: LP: #1493880, LP: #1493882, LP: #1514928.
  * Add private implementations to ActionItem, AbstractButton, BottomEdgeHint
    and BottomEdge. Fixes: LP: #1524234
  * Close Popups.Dialog when Esc key is pressed. Fixes LP: #1523833
  * Invoke the overridden trigger() function for Action and ActionItem
    derivates. Fixes LP: #1524234
  * Fix BottomEdge assertion when the content is committed by clicking on the
    hint. Fixes LP: #1524407

  [ CI Train Bot ]
  * No-change rebuild.

ubuntu-ui-toolkit (1.3.1742+16.04.20151209-0ubuntu1) xenial; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp:unity8) by: Daniel d'Andrada <email address hidden>.
  * Delete QQuickVi...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers