Popovers must close when rotating screen

Bug #1375837 reported by Ugo Riboni on 2014-09-30
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
High
Christian Dywan
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned
webbrowser-app (Ubuntu)
Medium
Unassigned
webbrowser-app (Ubuntu RTM)
Medium
Unassigned

Bug Description

After rotating the device a few times while an overflow menu is open, the menu will be placed in the wrong position on the screen. The number of rotations before this happens appears to be quite random, but it will eventually happen.

Below is a minimal example that should trigger the bug by rotating the device after opening the overflow menu:

import QtQuick 2.0
import Ubuntu.Components 1.1

MainView {
    id: mainView
    applicationName: "com.ubuntu.developer.ken-vandine.hub-importer"
    automaticOrientation: true
    useDeprecatedToolbar: false

    width: units.gu(100)
    height: units.gu(75)

    Page {
        title: "Test"

        head.actions: [
            Action { name: "Item 1" },
            Action { name: "Item 2" },
            Action { name: "Item 3" },
            Action { name: "Item 4" }
        ]
    }
}

Related branches

Tim Peeters (tpeeters) wrote :

Discussed this with Giorgio, and all Popovers (including header overflow panels, but NOT including dialogs) must close when screen is rotated.

summary: - Header overflow menu position wrong after rotating device with menu open
+ Popovers must close when rotating screen
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
assignee: nobody → Christian Dywan (kalikiana)
tags: added: rtm14
Changed in ubuntu-ui-toolkit:
importance: Undecided → High
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision 1268, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
milestone: none → 10.09
Olivier Tilloy (osomon) wrote :

Marked webbrowser-app also affected, because it uses a custom header, and its overflow menu currently isn’t implemented using a popover, so it won’t benefit from the UITK fix.

Changed in webbrowser-app:
importance: Undecided → Medium
status: New → Triaged
Zoltan Balogh (bzoltan) on 2014-11-19
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) on 2015-06-08
Changed in webbrowser-app (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in webbrowser-app (Ubuntu RTM):
status: New → Triaged
importance: Undecided → Medium
no longer affects: webbrowser-app
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu Vivid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers