Editing alarm sounds doesn't actually change them

Bug #1364949 reported by Dave Morley on 2014-09-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Critical
Charles Kerr
Ubuntu UI Toolkit
Fix Released
Critical
Zsombor Egri
indicator-datetime (Ubuntu)
Undecided
Unassigned
qtorganizer5-eds (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

STEPS:
1. Open the clock app
2. Swipe up from the bottom
3. Click on the + symbol
4. Save an alarm for a few minutes time leave everything on default settings
5. Click on save
6. Click on the alarm
7. Change the sound of the alram
8. Click on save
9. Let the alarm go off

EXPECTED:
I expected the sound I chose to play

ACTUAL:
The default harps played instead.

Related branches

tags: added: exploratory rtm14 testcase
Dave Morley (davmor2) on 2014-09-03
tags: added: flo krillin mako manta
removed: rtm14
Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → rtm
tags: added: rtm14
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Changed in ubuntu-clock-app:
status: Confirmed → Invalid
Nekhelesh Ramananthan (nik90) wrote :

Just is the task.ics file that after updating the alarm. http://paste.ubuntu.com/8223955/ The interesting part is the two alarm sounds that are present in that file for one alarm.

no longer affects: ubuntu-clock-app
Nekhelesh Ramananthan (nik90) wrote :

Another interesting tidbit, just before the alarm.save() function is called in the clock app, I outputted the alarm.sound property which correctly shows the sound chosen by the user indicating that something went wrong after the save() function call.

Zsombor Egri (zsombi) on 2014-09-04
Changed in ubuntu-ui-toolkit:
importance: Undecided → Critical
assignee: nobody → Zsombor Egri (zsombi)
Zsombor Egri (zsombi) on 2014-09-04
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Zsombor Egri (zsombi) wrote :

The sound is saved in the organiser event description as well to keep the sound URL even of the audible reminder is removed. The problem is that when only the alarm sound is changed, the audible reminder wasn't updated. So the error.

Zoltan Balogh (bzoltan) on 2014-09-12
Changed in ubuntu-ui-toolkit:
milestone: none → september-2014
Zsombor Egri (zsombi) on 2014-09-12
Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed

This bug still appears to be there

Zsombor Egri (zsombi) wrote :

Don't know what happened recently in EDS backend, but all I find now is that I cannot run the Alarm unit tests twice consecutively so I get the same results. One run produces 4 failures, then depending on how soon I run the next I get 1-4 failures... And between these the sound update fails once...

Zsombor Egri (zsombi) wrote :

EDS backend seems got some changes and/or some unimplemented things.

First, when UITK Alarm tests are run, which are all asynchronous, I have to add 400 msec wait time after each request wait completion, otherwise tests are failing randomly.

Second, when I update the type in an alarm, I'm getting an organizer item ID that has not been registered so far, and comparison is done using the QOrganizerItemId comparison. See paste bin [1]. However, when the sound is updated, I do get the changes perfectly, see [2]. But the IDs are still different for some reason.

Third, tags saving aint seem to work on EDS either. See logs for it in [2]. Note ALARMTAG and DISABLEDTAG logs show false, which is bad.

[1] http://pastebin.ubuntu.com/8464441/
[2] http://pastebin.ubuntu.com/8464733/
[3] http://pastebin.ubuntu.com/8464690/

Zsombor Egri (zsombi) on 2014-10-01
Changed in ubuntu-ui-toolkit:
status: Fix Committed → In Progress
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
milestone: september-2014 → 10.09
tags: added: touch-2014-10-09
Zsombor Egri (zsombi) wrote :

Charles, no matter what sound I set in the tests, indicator plays the same "Suru arpeggio" sound. I guess you are aware of this, but we got this bug re-opened because of that.

Changed in indicator-datetime:
importance: Undecided → Critical
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2014-10-07
Changed in indicator-datetime:
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Thomas Strehl (strehl-t) on 2014-10-09
tags: added: touch-2014-10-16
removed: touch-2014-10-09
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+14.10.20141009-0ubuntu1

---------------
indicator-datetime (13.10.0+14.10.20141009-0ubuntu1) utopic; urgency=low

  [ Charles Kerr ]
  * Fix appointment comparison function to include the audio_url field
    in its test. (LP: #1364949)
 -- Ubuntu daily release <email address hidden> Thu, 09 Oct 2014 13:35:53 +0000

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released
Ted Gould (ted) on 2014-10-10
Changed in indicator-datetime:
status: In Progress → Fix Released
Olli Ries (ories) on 2014-10-10
tags: added: touch-2014-10-23
removed: touch-2014-10-16
tags: added: touch-2014-10-16
removed: touch-2014-10-23
Zsombor Egri (zsombi) on 2014-10-18
Changed in qtorganizer5-eds (Ubuntu):
status: New → Invalid
Tim Peeters (tpeeters) on 2014-10-24
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu Vivid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints