Toggling an alarm status right after editing it results in the alarm status being reverted

Bug #1360101 reported by Nekhelesh Ramananthan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Critical
Zsombor Egri
ubuntu-ui-toolkit (Ubuntu)
Fix Released
Undecided
Unassigned
Vivid
Fix Released
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Create an alarm and save it.
2. Edit that alarm and change any property and then save it again.
3. Change the status of the alarm to disabled.

What happens:
Notice that the alarm status is reverted back to enabled

What should happen:
The alarm status stays disabled

Tags: rtm14

Related branches

Zsombor Egri (zsombi)
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
assignee: nobody → Zsombor Egri (zsombi)
tags: added: rtm14
Revision history for this message
Zsombor Egri (zsombi) wrote :

The issue is that somehow QOrganizer saves more reminder details, at least deleting the reminder once is not enough...

Zsombor Egri (zsombi)
Changed in ubuntu-ui-toolkit:
importance: Undecided → Critical
status: Confirmed → In Progress
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan)
Changed in ubuntu-ui-toolkit:
milestone: none → 10.09
Revision history for this message
Zsombor Egri (zsombi) wrote :

This has been released some time ago...

Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu Vivid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers