Alarm model is updated after every change causing all the listview items to be repainted

Bug #1359112 reported by Nekhelesh Ramananthan on 2014-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
High
Zsombor Egri
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

At the moment any change made to an alarm results in the entire alarm model being updated. This in turn causes the listview to be repainted which can cause the UI elements to reinitialize causing a flicker. In the clock app for instance, for every alarm operation like enabling/disabling an alarm, creating a new alarm etc, results in the listview to be repainted. This is expensive operation and also since the UI elements are repainted it causes some flicker.

Related branches

Zsombor Egri (zsombi) on 2014-08-20
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
assignee: nobody → Zsombor Egri (zsombi)
importance: Undecided → Medium
Zsombor Egri (zsombi) on 2014-08-22
tags: added: rtm14
Changed in ubuntu-ui-toolkit:
importance: Medium → Critical
importance: Critical → High
Zsombor Egri (zsombi) on 2014-08-22
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision 1209, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
milestone: none → 10.24
Zsombor Egri (zsombi) wrote :

This has been released long time ago.

Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Zsombor Egri (zsombi) on 2015-07-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers