Landing 06-08 has a visual bug due to square overflow tab panel

Bug #1354036 reported by Nekhelesh Ramananthan on 2014-08-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
High
Tim Peeters
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

On testing landing 06-08 (silo 15) I noticed the following visual bug in the clock app, reminders app and a couple of other apps which used tabs. The text displayed in the overflow tab is barely visible due to the hardcoded color which works only when the app background is light.

I have attached 4 screenshots below illustrating the issue.

Related branches

Nekhelesh Ramananthan (nik90) wrote :

Clock App Bug where the clock tab font color makes it hard to read the tab names in the overflow

Nekhelesh Ramananthan (nik90) wrote :

Reminder app icon bug in the overflow menu shown as a black rectangle.

Nekhelesh Ramananthan (nik90) wrote :

Bug in 3rd party app Flashback

Tim Peeters (tpeeters) wrote :

Would it make sense to use the header foreground (buttons + title) color, with a (~0.8/0.9) opacity?

Zoltan Balogh (bzoltan) on 2014-08-07
Changed in ubuntu-ui-toolkit:
assignee: nobody → Tim Peeters (tpeeters)
status: New → Confirmed
importance: Undecided → High
Changed in ubuntu-ui-toolkit:
assignee: Tim Peeters (tpeeters) → Christian Dywan (kalikiana)
Christian Dywan (kalikiana) wrote :

> The text displayed in the overflow tab is barely visible due to the hardcoded color which works only when the app background is light

The related branches don't solve this one. It may need public API but I'll rather leave this part to Tim as he worked on the color API.

Changed in ubuntu-ui-toolkit:
assignee: Christian Dywan (kalikiana) → Tim Peeters (tpeeters)
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) wrote :

This bug is confusing, it describes issues with text color, but also talks about black squares for icons. Please open new separate bugs for each of the issues if they are not fixed yet.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Tim Peeters (tpeeters) on 2014-09-22
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Zsombor Egri (zsombi) on 2015-07-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers