Alarm sound url read from a saved alarm is always empty

Bug #1338697 reported by Nekhelesh Ramananthan on 2014-07-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
High
Zsombor Egri
Ubuntu UI Toolkit
Fix Released
Critical
Zsombor Egri
qtorganizer5-eds (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

In the clock app, I am trying to add the option to set custom sounds for an alarm. Creating a new alarm and choosing a custom sound works properly. When the alarm is triggered, it rings using the correct sound. However when you read that alarm from the alarm model and output the sound url, it is always empty. As a result, one cannot check an alarm to see what sound was assigned to it.

I have created a sample alarms app to illustrate the issue at lp:~nik90/ubuntu-clock-app/alarmtest

Steps to reproduce bug:
1. Create a new alarm by pressing the + header button
2. Set alarm to ring in the next 10-15 seconds
3. Set a custom alarm sound by choosing one in the option selector
4. Save alarm

In the main page, click on the created alarm

What happens:
The alarm sound value is empty

What should happen:
The alarm sound correctly points to the path of the chosen sound

Related branches

description: updated
description: updated
Christian Dywan (kalikiana) wrote :

I've debugged this a bit, and it appears the sound gets set initially from the backend but gets lost somewhere after filling in the alarms model.

So in code modules/Ubuntu/Components/plugin/ucalarmmodel.cpp refresh() Q_FOREACH(const AlarmData &data, alarms) will not have the sound anymore even if it was correctly set in modules/Ubuntu/Components/plugin/adapters/alarmsadapter_organizer.cpp completeFetchAlarms

It seems as if something clears the sound accidentally but I can't find what that is… nothing sets the sound other than through the property. And the other values are consistently fine.

It *may* be backend-related as the "memory" backend never loads the saved sound, wheras "eds" has the issue as described where it gets lost before the UI makes use of it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtorganizer5-eds (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Changed in ubuntu-ui-toolkit:
assignee: nobody → Zsombor Egri (zsombi)

What I found is that the sound data is getting lost inside of SDK alarm API. It get the correct data from EDS fills the alarm object with the value but, in QML object in the property sound is empty.

Is very difficult t track where the sound property is getting lost, I think only Zsombor will be able to find it, I have already spent more than 2 hours on that without success.

Changed in qtorganizer5-eds (Ubuntu):
status: Confirmed → Invalid
Nekhelesh Ramananthan (nik90) wrote :

Marking ubuntu clock app as affected to track it in the rtm milestone.

Changed in ubuntu-clock-app:
importance: Undecided → High
milestone: none → rtm
status: New → Triaged
Zsombor Egri (zsombi) on 2014-08-06
Changed in ubuntu-ui-toolkit:
importance: Undecided → Critical
Zsombor Egri (zsombi) on 2014-08-06
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Changed in ubuntu-clock-app:
assignee: nobody → Zsombor Egri (zsombi)
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
Zsombor Egri (zsombi) on 2015-07-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints