Activity Indicator crashes in QML/Widget mixed applications

Bug #1338602 reported by Benjamin Zeller on 2014-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
High
Benjamin Zeller
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

ActivityIndicator can crash a application with SEGFAULT, usually at least 2 have to be used on the same view.

The bug seems to only happen in a mixed application, where a QQuickView is used inside a QWidget based application (like the DevicesPage in the Ubuntu QtC plugin) and the QML view is hidden and shown again.

A simple example is available here:

https://code.launchpad.net/~zeller-benjamin/+junk/indicator-crash

I'm on Utopic + Qt 5.3, probably its related to the new Qt version because that problem came up roughly at the same time when we made the switch to
Qt 5.3.

Update:
This was fixed by upstream in Qt 5.3.1, once we get there (or backport the fix) we can remove the workaround

Related branches

Added a full backtrace

description: updated
Tim Peeters (tpeeters) wrote :

cannot reproduce on trusty with qt 5.2.1

Created a upstream bug:

https://bugreports.qt-project.org/browse/QTBUG-40111

I was able to reproduce that with Qt 5.3.0 downloaded from qtproject.org.

Zsombor Egri (zsombi) on 2014-08-13
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
assignee: nobody → zbenjamin (zeller-benjamin)
importance: Undecided → High
description: updated
Timo Jyrinki (timo-jyrinki) wrote :

The Qt Declarative part is being handled in bug #1356279

Timo Jyrinki (timo-jyrinki) wrote :

The Qt Declarative got released last Friday so this is fixed in 14.10 and was apparently not present in the Qt 5.2.1 in 14.04 LTS.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Committed
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Zsombor Egri (zsombi) on 2015-07-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments