The gallery_app tests started failing because the toolbar is closed by the time we try to click the button

Bug #1302706 reported by Leo Arias on 2014-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Unassigned
gallery-app
Fix Released
Undecided
Leo Arias
gallery-app (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Leo Arias

Bug Description

We started seeing some failures on the gallery app

http://pastebin.ubuntu.com/7203598/

It seems that we try to click the button when the toolbar is opened, but by the time we have selected the autopilot button the toolbar it's already closed. Autopilot takes just a few milliseconds to select the button, so the window for the app to get this error is really small. But anyway, we can make the window smaller by making the check before selecting the button.

Related branches

Leo Arias (elopio) on 2014-04-04
Changed in ubuntu-ui-toolkit:
status: New → In Progress
Leo Arias (elopio) on 2014-04-04
Changed in gallery-app:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gallery-app - 0.0.67+14.04.20140408.1-0ubuntu1

---------------
gallery-app (0.0.67+14.04.20140408.1-0ubuntu1) trusty; urgency=low

  [ Bill Filler ]
  * skip broken test until root cause can be found

  [ Arthur Mello ]
  * Make sure that album cover will be not behind header at album edit
    screen (LP: #1294291)
  * Add unittest to check if only videos on the correct path are beeing
    added to gallery on device
  * Add an overlay play icon over Video preview on media navigation (LP:
    #1294282)
  * Apply a similar workaround to the one suggested by Zsombor to work
    around bug #1296832 to temporarily replace MouseAreas within
    PinchAreas (LP: #1296832, #1288695)

  [ Ugo Riboni ]
  * Fix album navigation, allowing to page all the way to the last page,
    and to close the album by paging to the cover. (LP: #1287355)
  * Apply a similar workaround to the one suggested by Zsombor to work
    around bug #1296832 to temporarily replace MouseAreas within
    PinchAreas (LP: #1296832, #1288695)
  * fix autopilot test

  [ Leo Arias ]
  * Properly override the toolkit toolbar autopilot helper.
  * On the autopilot helpers to click a toolbar button, check that the
    toolbar is opened first. (LP: #1302706)
 -- Ubuntu daily release <email address hidden> Tue, 08 Apr 2014 18:51:30 +0000

Changed in gallery-app (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20140408.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20140408.1-0ubuntu1) trusty; urgency=low

  [ Zoltán Balogh ]
  * Change Ubuntu API links in the docs (LP: #1303535) (LP: #1303535)

  [ Leo Arias ]
  * Improve the check of tab selection mode by moving to it first.
  * On the autopilot helpers to click a toolbar button, check that the
    toolbar is opened first. (LP: #1302706)

  [ tpeeters ]
  * Improve toolbar handling on desktop by opening it on mouse hover.
    (LP: #1182734)
  * If a Page is inside a Tab and has no title set, get it automatically
    from the Tab. (LP: #1289695)
 -- Ubuntu daily release <email address hidden> Tue, 08 Apr 2014 14:47:06 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Leo Arias (elopio) on 2014-04-21
Changed in gallery-app:
assignee: nobody → Leo Arias (elopio)
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Leo Arias (elopio)
Zoltan Balogh (bzoltan) on 2014-11-14
Changed in ubuntu-ui-toolkit:
status: In Progress → Won't Fix
Zoltan Balogh (bzoltan) on 2014-11-19
Changed in ubuntu-ui-toolkit:
status: Won't Fix → Fix Released
Changed in gallery-app:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers