TabBar unit tests fail in UI toolkit when building against Qt 5.2 RC1

Bug #1256930 reported by Zsombor Egri on 2013-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Critical
Zsombor Egri
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

The following failures occur:

FAIL! : components::TabBarAPI::test_0_selectionMode() default selectionMode
   Actual (): false
   Expected (): true
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(92)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 0) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 1) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 2) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 3) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 4) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 5) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 6) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 7) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 8) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 9) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 10) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 11) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 12) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 13) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 14) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]
FAIL! : components::TabBarAPI::test_2_tabSelection(row 15) TabBar is no longer in selection mode
   Actual (): true
   Expected (): false
   Loc: [/home/zsombor/projects/canonical/work/qt52-buildfix/tests/unit_x11/tst_components/tst_tabbar.qml(157)]

Related branches

Zsombor Egri (zsombi) wrote :

Seems it has to do with the test cases not showing up. Most likelly nees to be checked with tests/unit_x11/tst_components.

tags: added: qt5.2
Zsombor Egri (zsombi) wrote :

Checked against latest Qt5.2.0 builds, all unit tests pass.

Changed in ubuntu-ui-toolkit:
status: New → Invalid
Zsombor Egri (zsombi) wrote :

Seems it still fails for some of us...

Changed in ubuntu-ui-toolkit:
status: Invalid → Confirmed
Bill Filler (bfiller) on 2014-01-21
Changed in ubuntu-ui-toolkit:
assignee: nobody → Zsombor Egri (zsombi)
Zsombor Egri (zsombi) wrote :

With the latest Qt5.2 builds seems the only failure happens in components::TabBarAPI::test_0_selectionMode() default selectionMode.

Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20140212-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20140212-0ubuntu1) trusty; urgency=low

  [ Andrew Hayzen ]
  * Fixed text not aligned at vertical centre if the listitem height has
    changed dynamically. Fixed no removeItemAnimation if the listitem
    height has been set. (LP: #1263688, #1263682)

  [ CI bot ]
  * Trunk as is, for CI Train release.

  [ William Hua ]
  * Also update LANGUAGE when setLanguage is called for dynamic
    translation. (LP: #1263163). (LP: #1263163)

  [ Timo Jyrinki ]
  * A qtdeclarative5-private-dev packaging change adding a dependency on
    libqt5v8-5-private-dev has been backported to all Ubuntu versions
    now, so this workaround can now be dropped - building both against
    Qt 5.2 and 5.0.2 works.
  * Add #include for QDebug to fix Qt 5.2 build.

  [ Christian Dywan ]
  * Split build and install steps in debian/rules.
  * Use integer Date constructor in date picker tests for Qt 5.2.
  * Run unit_x11 test cases via Xvfb and address failures. (LP:
    #1258017, #1237812, #1242646)
  * Don't redirect output of the input file in itself.
  * Don't try to deploy non-existing qml and js files. (LP: #1259228)
  * Assert textField focus, button visibility and pressed after tapping
    clear.
  * Split documentation for previously group properties. (LP: #1266842)
  * Suppress errors to work-around font error messages. (LP: #1256999)
  * ListItems.Empty's default property needs to be data not children.
    (LP: #1190509)

  [ Pete Woods ]
  * Handle the unity-action-api quit signal. (LP: #1269409)

  [ Zsombor Egri ]
  * Date picker component. Provides full date and month only picking
    functionality.
  * DatePicker test case fix, setting the minimum limit to value that is
    earlier than the date value set. (LP: #1266515)
  * Fixing state restoration when nested dynamic component properties
    are restored. (LP: #1267039)
  * Removing obsolete functionality from QuickUtils. (LP: #1266707)
  * StateSaver failure with Repeater fixed. Indirectly fixes StateSaver
    with ListView and GridView. (LP: #1267900)
  * TabBar test case failure fix for Qt5.2. (LP: #1256930)
  * InverseMouseArea API test removed, being a duplicate of the other
    InverseMouseArea tests. Connecting to th eproper enabledChanged
    signal in InverseMouseArea resolves the warning in Qt5.2 stating
    enabledChanged was overwritten in QQuickMouseArea. (LP: #1266707)
  * Panel implementation for DatePicker. Presents the DatePicker either
    in a panel covering the OSK area or in a Popover, depending on the
    form factor and presence of input method provider.
  * Layout tests now wait for the currentLayout change completion. (LP:
    #1266707)
  * Extra QQmlEngine instance removed from plugin, which seemed to cause
    some race conditions with Qt5.2. As result UbuntuColors got
    transferred from context property into singleton object, Theme's
    palette creation delayed till its first access. (LP: #1266707)
  * DateUtils test failure fix. (LP: #1273893)

  [ Florian Boucault ]
  * Ubuntu UI Toolkit Gallery: reimplemented in a cleaner way the
    respo...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Tim Peeters (tpeeters) on 2014-03-09
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers