Fix property naming for OptionSelector/ItemSelector

Bug #1254646 reported by Tim Peeters
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Won't Fix
Medium
Unassigned

Bug Description

OptionSelector and ItemSelector have these two properties:

    /*!
      \preliminary
      Specifies whether the list is always expanded.
     */
    property bool expanded: false

    /*!
      \qmlproperty bool expanded
      Is our list currently expanded?
     */
    readonly property alias currentlyExpanded: listContainer.currentlyExpanded

The name "expanded" is not clear, "alwaysExpanded" would be better. "currentlyExpanded" should be named "expanded" (we don't use the currently- prefix anywhere else).

I propose to rename "expanded" to "alwaysExpanded" (keep expanded as deprecated for a while), and once the old deprecated "expanded" has been removed, "currentlyExpanded" can be deprecated in favor of a new "expanded".

Tim Peeters (tpeeters)
Changed in ubuntu-ui-toolkit:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.