Several apps have failing tests with 20131003 ui-toolkit

Bug #1234544 reported by Timo Jyrinki
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Critical
Nicholas Skaggs

Bug Description

As discussed on IRC, upgrading to ubuntu-ui-toolkit version from today breaks all weather app tests, 3/7 terminal app tests, 2/2 rssreader app tests (https://pastebin.canonical.com/98420/). No further app testing was done because of the found reproducible problems. Reverting to archive version of ubuntu-ui-toolkit immediately fixed all the failing tests.

ui-toolkit's own AP tests function alright.

Related branches

description: updated
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

before these changes, the path was something like:
 ~/.local/share/Qt Project/...
 after it is something like:
 ~/.local/share/$applicationName/...

If tests are coded to look at the previous path they will need updating.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

The fix for bug /1231863 seems to have triggered this

Changed in ubuntu-ui-toolkit:
assignee: nobody → Nicholas Skaggs (nskaggs)
Revision history for this message
Francis Ginther (fginther) wrote :

Looks like the problem is that the apps hardcoded the db path which has now changed via the fix for lp:1231863.

Example from weather-app:

 'dbs_path = os.path.expanduser("~/.local/share/Qt Project/QtQmlViewer/QML/OfflineStorage/Databases/")'

Revision history for this message
Nicholas Skaggs (nskaggs) wrote :
Changed in ubuntu-ui-toolkit:
status: New → In Progress
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

Is it possible to provide a library call of some kind that properly constructs the path using the right app name? Then all tests use that rather than a hardcoded path.

Revision history for this message
Nicholas Skaggs (nskaggs) wrote :

The long term plan is to use a property via the UITK emulator for this. This is considered the short-term fix so we can land this stuff. Leo is working on the changes to the emulator to support this idea.

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

FYI, looking at these commits at least some of the apps are using the wrong applicationName. See 'Runtime Environment' in http://developer.ubuntu.com/publish/apps/security-policy-for-click-packages/ for details. In essence, if these apps move to click packages, they need to update their applicationName in the MainView {} of their QML to match that of the "name" field of the click manifest to run at all. Once that is done though, the autopilot tests will fail again because they will be looking for the files in the wrong place. I suggesting working with serguisens on what to change the applicationName to (since he has been working on packaging these as click), and then adjust the autopilot tests accordingly.

FYI, QtCreator now does all this correctly when developing new applications, so this shouldn't be a problem with new apps.

Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints