Local Sqlite databases are still created/stored in incorrect location

Bug #1231863 reported by Nekhelesh Ramananthan on 2013-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Critical
Christian Dywan
apparmor-easyprof-ubuntu (Ubuntu)
High
Unassigned
Saucy
High
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Critical
Unassigned
Saucy
Critical
Unassigned

Bug Description

Commit rev 752 was supposed to fix bug https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1197051, however on testing it with the clock app, the local sqlite database is still being created in .local/share/Qt Project/QML/OfflineStorage/Databases/... instead of in .local/share/app-name.

Related branches

summary: - Local Sqlite databases are still stored in incorrect location
+ Local Sqlite databases are still created/stored in incorrect location
Changed in ubuntu-ui-toolkit:
assignee: nobody → Christian Dywan (kalikiana)
importance: Undecided → Critical
status: New → Confirmed
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Jamie Strandboge (jdstrand) wrote :

Adding an apparmor-easyprof-ubuntu task as it will need to update policy to remove the workaround.

tags: added: application-confinement
Changed in ubuntu-ui-toolkit (Ubuntu Saucy):
importance: Undecided → Critical
status: New → Triaged
Changed in apparmor-easyprof-ubuntu (Ubuntu Saucy):
status: New → Triaged
importance: Undecided → High
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20131007-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20131007-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Add default tools (LP: #1233709). (LP: #1233709)

  [ Loïc Molinari ]
  * Added URI handler support.
  * Fixed UbuntuShape warnings when using a ShaderEffectSource as an
    image.

  [ <email address hidden> ]
  * Added test cases for text field testing.
  * Minor change to make the OptionSelector more testable by adding
    objectName property to uniquely identify the object. (LP: #1234020)

  [ Christian Dywan ]
  * Set offline storage path and add a unit test. (LP: #1231863)
  * Emit domainChanged from bindtextdomain to trigger updates. (LP:
    #1220395)
  * Support TextArea used with an action.
  * Support option selector used with an action.
  * Add haptic feedback to AbstractButton. (LP: #1189537)

  [ Zsombor Egri ]
  * Fix Picker module deployment.
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Jussi Pakkanen ]
  * Adds thumbnailer image provider.

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Andrea Cimitan ]
  * Export a position value of the toolbar through dbus, setting the
    value of the dbus service created by the shell. (LP: #1224480)

  [ Guenter Schwann ]
  * Better handle the case of dismissing the OSK and focusing the text
    again fixes LP: #1228155. (LP: #1228155)

  [ Renato Araujo Oliveira Filho ]
  * Added "confirmRemoval" in ListItem.Empty This will ask for
    confirmation before remove the item. (LP: #1213046)
  * Disabled confirmation on swipe to delete as default.

  [ Leo Arias ]
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 786
 -- Ubuntu daily release <email address hidden> Mon, 07 Oct 2013 04:36:33 +0000

Changed in ubuntu-ui-toolkit (Ubuntu Saucy):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor-easyprof-ubuntu - 1.0.35

---------------
apparmor-easyprof-ubuntu (1.0.35) saucy; urgency=low

  * apparmor-easyprof-ubuntu.install: install data/hardware/*, thus allowing
    porters, OEMs, etc to ship their own policy without having to modify this
    package (LP: #1197133)
  * add data/hardware/graphics.d/* and data/hardware/audio.d/*, namespaced to
    this package. We will move these out to lxc-android-config later
  * tests/test-data.py: adjust to test data/hardware/*
  * accounts: move to reserved status until LP: 1230091 is fixed
  * calendar: remove workaround rule for gio DBus path (LP: #1227295)
  * add usermetrics policy group so apps can update the infographic
  * ubuntu-* templates:
    - allow StartServiceByName on the system bus too. This is needed by the
      new usermetrics policy group and we will presumably have more going
      forward (eg location)
    - account for /org/freedesktop/dbus object path. This seems to be used by
      the python DBus bindings (eg, friends)
    - move hardware specific accesses out of the templates into
      hardware/graphics.d/ in preparation of the move to shipping these in
      lxc-android-config (note, this doesn't change apparmor policy in any
      way)
    - add 'r' to dbus system bus socket (LP: #1208988)
    - add ixr access to thumbnailer helper (LP: #1234543)
    - finetune HUD access
    - don't use ibus abstraction but instead use 'r' access for
      owner @{HOME}/.config/ibus/**
    - don't use freedesktop.org abstraction but instead add read accesses
      for /usr/share/icons and various mime files
    - updates for new gstreamer
      - move in gstreamer accesses from audio policy groupd due to hybris
  * ubuntu-sdk template:
    - remove workaround paths now that ubuntu-ui-toolkit is using
      QCoreApplication::applicationName based on MainView's applicationName
      (LP: #1197056, #1197051, #1224126, LP: #1231863)
  * ubuntu-webapp template:
    - allow read access to /usr/share/unity-webapps/userscripts/**
    - allow rix to gst-plugin-scanner
  * add reserved friends policy group (reserved because it needs integration
    with trust-store to be used by untrusted apps)
  * remove peer from receive DBus rules in the ubuntu-* templates and the
    contacts, history, and location policy groups (LP: #1233895)
  * audio:
    - move gstreamer stuff out to templates since hybris pulls it in for all
      apps
    - include hardware/audio.d for hardware specific accesses
 -- Jamie Strandboge <email address hidden> Mon, 07 Oct 2013 13:18:27 -0500

Changed in apparmor-easyprof-ubuntu (Ubuntu Saucy):
status: Triaged → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints