unity needs applications to inform about some details on a desktop file

Bug #1227355 reported by Leo Arias on 2013-09-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Leo Arias
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

A couple of days ago the autopilot tests in Ubuntu UI Toolkit and some other apps started failing. We found that qmlscene was not being launched on top of unity, and then autopilot could not interact with it.

The cause is a policy change on Unity. According to greyback:
In shell we're imposing a policy that any application that draws to screen, must inform shell of certain information (name, icon, stage) so shell can manage it properly. This info is what desktop file is for anyway, but there's no reliable way to find the desktop file for a process. So for now we demand this desktop_file_hint

So, we need to launch the applications on autopilot with a desktop_file_hint pointing to a file on a well know location like ~/.local/share/applications/. For the tests that write a QML from a string to a temp file, this means we will also have to create a temp desktop file. For the tests that use a QML application from source, we will need to move their desktop file to ~/.local/share/applications. For the tests that use an installed application, we can just use their installed .desktop file.

Related branches

Leo Arias (elopio) wrote :

Also from greyback: in not-too distant future, we'll be using upstart to launch all applications, and upstart will manage this for you

So, on the toolkit I'm cleaning the test cases code to make sure it's easier to change on the future.

Changed in ubuntu-ui-toolkit:
status: New → Confirmed
assignee: nobody → Leo Arias (elopio)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130925.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130925.1-0ubuntu1) saucy; urgency=low

  [ Timo Jyrinki ]
  * Temporarily disable the jokes example in order to not have
    qtmultimedia dependency from examples that is not used otherwise.
    This lessens the dependency chains of packages. It can be added back
    after Ubuntu 13.10.
  * Fix regression in qmlscene usage (LP: #1229541). (LP: #1229541)

  [ Christian Dywan ]
  * Set QCoreApplication::applicationName based on MainView. (LP:
    #1197056, #1197051, #1224126)
  * Include subfolders of Components in api check.

  [ Zsombor Egri ]
  * Organizer EDS (Evolution Data Server) integration.
  * StateSaver attached component.
  * Fix alarm status reporting, updating documentation on asynchronous
    behavior of save and cancel operations. Alarm status notification
    reports the operation the status refers to. (LP: #1226516)
  * Dialer + DialerHand components required for TimePicker. .

  [ Leo Arias ]
  * Added UbuntuUIToolkitAppTestCase as a base test case for the
    autopilot tests. (LP: #1227355)
  * Added the autopilot emulator for toggles.

  [ Nick Dedekind ]
  * Added clipping to tab bar. (LP: #1226104)

  [ Alberto Mardegan ]
  * Support re-attaching to a different QQuickView Make the plugin
    correctly handle the case when the QQuickView is destroyed and a new
    one is created: this is done by avoiding using static variables, and
    instead binding the data to the QQmlEngine, QQmlContext or QWindow
    as appropriate. . (LP: #1221707)

  [ Dennis O'Flaherty ]
  * Reword the description for easier reading.

  [ tpeeters ]
  * Fix warnings when running gallery-app autopilot tests. (LP:
    #1223329, #1223326)
  * Smarter automatic updating of Panel's opened property. Panel.open()
    and Panel.close() should be used to open/close a Panel, or when
    using a toolbar with ToolbarItems from a Page, set Page.tools.opened
    to open/close the toolbar. No API or behavior changes since the
    panel-open-close branch. Toolbar behavior changes will be done in a
    following MR.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 765
 -- Ubuntu daily release <email address hidden> Wed, 25 Sep 2013 07:08:56 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers