Hide toolbar when user interacts with tabs header

Reported by Tim Peeters on 2013-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Critical
Tim Peeters
Ubuntu UX
High
John Lea
ubuntu-ui-toolkit (Ubuntu)
Undecided
Tim Peeters

Related branches

lp:~tpeeters/ubuntu-ui-toolkit/tabbar-closes-toolbar
Rejected for merging into lp:ubuntu-ui-toolkit
Tim Peeters: Disapprove on 2013-11-28
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-11-26
Christian Dywan: Pending requested 2013-11-26
lp:~tpeeters/ubuntu-ui-toolkit/tabbar-closes-toolbar2
Merged into lp:ubuntu-ui-toolkit at revision 866
PS Jenkins bot: Approve (continuous-integration) on 2013-11-27
Christian Dywan: Approve on 2013-11-27
Tim Peeters (tpeeters) on 2013-09-10
Changed in ubuntu-ui-toolkit:
importance: Undecided → Critical
assignee: nobody → Tim Peeters (tpeeters)
summary: - Show toolbar when user interacts with tabs header
+ Hide toolbar when user interacts with tabs header
Tim Peeters (tpeeters) on 2013-09-10
tags: added: tabs toolbar
Changed in ubuntu-ui-toolkit:
importance: Critical → Undecided
John Lea (johnlea) on 2013-09-11
Changed in ubuntu-ux:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
Tim Peeters (tpeeters) on 2013-09-11
Changed in ubuntu-ui-toolkit:
importance: Undecided → High
status: New → Confirmed
Tim Peeters (tpeeters) on 2013-09-11
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Tim Peeters (tpeeters) on 2013-09-17
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) on 2013-09-18
Changed in ubuntu-ui-toolkit:
status: In Progress → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Confirmed
John Lea (johnlea) on 2013-10-04
tags: added: sabdfl-ux-requests
Tim Peeters (tpeeters) wrote :

Should the toolbar close when the user touches the tab area to activate the tabbar, or also when the tabbar is already opened (initially) and the user touches it, for example to switch tabs? I am asking because when switching tabs, chances are high that the toolbar will need to open again to show the tools available in the newly selected tab.

Tim Peeters (tpeeters) on 2013-11-11
Changed in ubuntu-ux:
status: Fix Committed → Confirmed
Tim Peeters (tpeeters) wrote :

This bug https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1223600 needs to be fixed first in order to make the desired toolbar behavior easy to implement.

Tim Peeters (tpeeters) on 2013-11-25
Changed in ubuntu-ui-toolkit:
importance: High → Critical
Tim Peeters (tpeeters) on 2013-11-25
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) wrote :

Bug link in my comment above is wrong. This is the bug that needs fixing first: https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1250194

That is fixed now, so I can work on this bug.

Tim Peeters (tpeeters) on 2013-11-27
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Tim Peeters (tpeeters)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision 866, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) on 2013-11-28
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20131129-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20131129-0ubuntu1) trusty; urgency=low

  [ Zsombor Egri ]
  * Tabs to react on model changes when a Repeater is used to populate
    with Tab components. . (LP: #1255544)

  [ Leo Arias ]
  * Added a ComposerSheet autopilot emulator. (LP: #1248740)

  [ Nic ]
  * Made currentlyExpanded property writeable. Fixed up comments for
    incorrectly documented properties. Added a positionViewAtIndex to
    refocus the list on the first index when it's externally collapsed.
    (LP: #1252718)

  [ Nicolas d'Offay ]
  * Made currentlyExpanded property writeable. Fixed up comments for
    incorrectly documented properties. Added a positionViewAtIndex to
    refocus the list on the first index when it's externally collapsed.
    (LP: #1252718)

  [ tpeeters ]
  * Detect interaction with contents (in order to close toolbar/tabbar)
    from Page to MainView.
  * Close the toolbar when user activates tabbar. (LP: #1223600)
  * Close tabbar on toolbar interaction. (LP: #1223606)
  * Disable header animations at app startup. (LP: #1246792)

  [ Christian Dywan ]
  * Elaborate on why OrientationHelper's internal must be Item.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 872
 -- Ubuntu daily release <email address hidden> Fri, 29 Nov 2013 20:24:58 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Tim Peeters (tpeeters) on 2013-12-02
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints