Tab bar must be activated initially

Reported by Tim Peeters on 2013-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
High
Tim Peeters
Ubuntu UX
Critical
John Lea
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Related branches

lp:~tpeeters/ubuntu-ui-toolkit/tabs-autoactive
Merged into lp:ubuntu-ui-toolkit at revision 808
PS Jenkins bot: Approve (continuous-integration) on 2013-10-25
Tim Peeters: Approve on 2013-10-25
Zsombor Egri: Approve on 2013-09-17
Tim Peeters (tpeeters) on 2013-09-10
Changed in ubuntu-ui-toolkit:
importance: Undecided → Critical
assignee: nobody → Tim Peeters (tpeeters)
Tim Peeters (tpeeters) on 2013-09-10
Changed in ubuntu-ui-toolkit:
importance: Critical → Undecided
John Lea (johnlea) on 2013-09-11
Changed in ubuntu-ux:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
Tim Peeters (tpeeters) on 2013-09-11
Changed in ubuntu-ui-toolkit:
importance: Undecided → Critical
status: New → Confirmed
Tim Peeters (tpeeters) on 2013-09-11
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) on 2013-09-11
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → In Progress
Tim Peeters (tpeeters) on 2013-09-25
Changed in ubuntu-ui-toolkit:
importance: Critical → High
John Lea (johnlea) on 2013-10-04
tags: added: sabdfl-ux-requests
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) on 2013-11-04
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20131105.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20131105.1-0ubuntu1) trusty; urgency=low

  [ Albert Astals ]
  * Minor optimzations Add const & to foreach to save copies of
    "complex" types Remove initializations of QStrings to "" since they
    do nothing Return QString instead of "" since its faster Pass
    "complex" types as const & instead of copy to functions Not an
    optimization: Added const qualifier to two functions .

  [ Lars Uebernickel ]
  * Remove GIconProvider Use urls for file and data icons and the theme
    image provider (image://theme/) for themed icons.

  [ Kaleo ]
  * [visual design] Updated tabs chevron asset.

  [ Christian Dywan ]
  * Install translations for UI toolkit and gallery. (LP: #1239627)
  * Support checkbox used with an action.
  * Install autopilot modules in qmake not debian packaging.
  * Drop the $$ from system calls where output isn't needed.
  * Look for locale folder as per XDG basedir spec and rewrite test The
    new test case covers the whole range of changing languages, checking
    the strings from both QML and C++ and binding to a folder. (LP:
    #1175726, #1233071)
  * Define window within OrientationHelper to avoid a race condition.
    (LP: #1239760)

  [ Zsombor Egri ]
  * Support for taking themes from XDG_DATA_DIRS as well as from
    ~/.local/share. These paths are also added as import paths.
    UBUNTU_UI_TOOLKIT_THEMES_PATH overrules these import paths, and can
    have more than one path specified, each separated with column. (LP:
    #1221813)
  * Warnings treated as errors in all types of builds (debug or
    release). (LP: #1246290)
  * Introducing topmostItem property to drive whether InverseMouseArea
    should filter sensingArea events or to stay in the normal z-
    order/stack order of its parent. (LP: #1240460)

  [ Leo Arias ]
  * Added the go back method to the autopilot emulators. (LP: #1239751)
  * On the autopilot emulator, drag the toolbar to its full height. (LP:
    #1235060)
  * Initially show toolbar, but automatically hide after timeout. (LP:
    #1207369)
  * Added the change_state method to the CheckBox autopilot emulator.
    Cleaned up the autopilot gallery toggles tests.
  * Added the objectNames to the ComposerSheet buttons. (LP: #1244518)

  [ tpeeters ]
  * Update CrossFadeImage API so that sourceSize can be set by the
    applications. CHANGED in CrossFadeImage: readonly property size
    sourceSize TO property size sourceSize. (LP: #1227783)
  * Initially show toolbar, but automatically hide after timeout. (LP:
    #1207369)
  * Put tab bar in selection mode when apps are launched. (LP: #1223597)
  * Close tabbar and toolbar when user interacts with app contents. (LP:
    #1223604)

  [ Nicolas d'Offay ]
  * Added multiSelection bool and supporting code to OptionSelector and
    ItemSelector. This turns either component into a multiple choice
    selector. Fixed linked bugs. (LP: #1231936)

  [ Renato Araujo Oliveira Filho ]
  * Implemented emulator for swipe to remove. (LP: #1236464)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 820
 -- Ubu...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Tim Peeters (tpeeters) on 2013-11-07
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints