[OptionSelector] needs a "entry has been clicked" signal

Bug #1218250 reported by Sebastien Bacher on 2013-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Nicolas d'Offay
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

Current there is only has onSelectedIndexChanged signal, that's not enough because:

- there is no way to tell appart code selection and user selection (e.g if you set the index, for a component, when loading, you get the callback triggered)

- we want some actions to only happen on user action (e.g in the "ringtone selection" screen we want the preview to happen only when user click, not when the index is updated due to a config change)

- the design require for the actions to happen on click sometime even when the selection doesn't change (e.g in the "ringtone selection" case, clicking on the currently selected entry should preview the sound again)

Thanks for considering!

Related branches

Changed in ubuntu-ui-toolkit:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision 735, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130903.3-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130903.3-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Reverse cherrypicking rev734.

  [ Zsombor Egri ]
  * Branch 734 removed, causing Unity test failures.

  [ Nicolas d'Offay ]
  * Added ItemSelector. Extend OptionSelector and fixed various bugs.
    Added tests for both OptionSelector and ItemSelector. (LP: #1169258,
    #1218250, #1218247)

  [ tpeeters ]
  * New toolbar reveal/hide behavior, as specified by design. (LP:
    #1207369)

  [ <email address hidden> ]
  * This MP contains some fixes to autopilot test cases. Two test cases
    are commented for now as they were giving inconsistent results on
    phone. .

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 738
 -- Ubuntu daily release <email address hidden> Tue, 03 Sep 2013 11:46:19 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers