[OptionSelector] selectedIndex needs to be writable

Bug #1218247 reported by Sebastien Bacher on 2013-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Nicolas d'Offay
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

The property is currently read only, which means you can't select an entry by default.

In system settings we need to be able to select the entry matching the current configuration value...

Related branches

Changed in ubuntu-ui-toolkit:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision 735, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130903.3-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130903.3-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Reverse cherrypicking rev734.

  [ Zsombor Egri ]
  * Branch 734 removed, causing Unity test failures.

  [ Nicolas d'Offay ]
  * Added ItemSelector. Extend OptionSelector and fixed various bugs.
    Added tests for both OptionSelector and ItemSelector. (LP: #1169258,
    #1218250, #1218247)

  [ tpeeters ]
  * New toolbar reveal/hide behavior, as specified by design. (LP:
    #1207369)

  [ <email address hidden> ]
  * This MP contains some fixes to autopilot test cases. Two test cases
    are commented for now as they were giving inconsistent results on
    phone. .

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 738
 -- Ubuntu daily release <email address hidden> Tue, 03 Sep 2013 11:46:19 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers