[Address book] swipe to delete does not ask for confirmation

Reported by Omer Akram on 2013-08-16
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Undecided
Renato Araujo Oliveira Filho
Ubuntu UX
Medium
Christina Li
address-book-app
High
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
High
Renato Araujo Oliveira Filho
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

See swipe to delete pattern: https://docs.google.com/a/canonical.com/file/d/0B-a_7E3tDxOgN3E0ZFBzUHZxZjQ/edit

Desired solution:
When a user swipe on the list item (ie contact), a in-row prompt would appear. By tapping on the prompt would then remove the list item. Tapping outside of the prompt would return to the normal state.

See pattern website for details on deletion as we are working on updating the SDK component:
http://design.ubuntu.com/apps/global-patterns/deletion
=================================================

In the last two days I have mistakenly deleted two of my contacts just while playing with the app. swipe a contact right should atleast ask for a confirmation.

Related branches

lp:~renatofilho/ubuntu-ui-toolkit/fix-1213046
Merged into lp:ubuntu-ui-toolkit at revision 772
PS Jenkins bot: Approve (continuous-integration) on 2013-09-30
Bill Filler (community): Approve on 2013-09-30
Gustavo Pichorim Boiko (community): Needs Fixing on 2013-09-23
lp:~renatofilho/address-book-app/fix-1213046
Merged into lp:address-book-app at revision 96
Tiago Salem Herrmann: Approve on 2013-10-09
PS Jenkins bot: Approve (continuous-integration) on 2013-10-09
Christina Li (christina-li) wrote :

The upated delete component will have a form of confirmation- SDK toolkit in progress

Changed in ubuntu-ux:
assignee: nobody → Christina Li (christina-li)
status: New → Triaged
summary: - swipe to delete does not ask for confirmation
+ [Address book] swipe to delete does not ask for confirmation
Changed in ubuntu-ux:
status: Triaged → In Progress
Changed in ubuntu-ux:
importance: Undecided → Medium
description: updated
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Bill Filler (bfiller) wrote :

@christina
What is the fix here? Since it doesn't look like anyone is assigned on sdk team, what can we do short term to make it better? How about a confirmation dialog?

Changed in address-book-app:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in address-book-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Christina Li (christina-li) wrote :

@bill, design is sorting this through with SDK over the next few days, or we will decide on a temporary solution. will update this when I know more.

Changed in address-book-app:
assignee: Tiago Salem Herrmann (tiagosh) → Renato Araujo Oliveira Filho (renatofilho)
Changed in address-book-app (Ubuntu):
assignee: Tiago Salem Herrmann (tiagosh) → Renato Araujo Oliveira Filho (renatofilho)
Changed in address-book-app:
status: Confirmed → In Progress

I have implemented the initial support on SDK, and contact app.
I need to confir with designer the visual but the functionality is there already.

The current visual

Changed in address-book-app (Ubuntu):
status: Confirmed → In Progress
Christina Li (christina-li) wrote :

@renato- please refer to the image link for the swipe to delete pattern: https://docs.google.com/a/canonical.com/file/d/0B-a_7E3tDxOgN3E0ZFBzUHZxZjQ/edit

description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: New → Fix Committed
Pat McGowan (pat-mcgowan) wrote :

Be sure to fix addressbook tests affected by this change

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20131007-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20131007-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Add default tools (LP: #1233709). (LP: #1233709)

  [ Loïc Molinari ]
  * Added URI handler support.
  * Fixed UbuntuShape warnings when using a ShaderEffectSource as an
    image.

  [ <email address hidden> ]
  * Added test cases for text field testing.
  * Minor change to make the OptionSelector more testable by adding
    objectName property to uniquely identify the object. (LP: #1234020)

  [ Christian Dywan ]
  * Set offline storage path and add a unit test. (LP: #1231863)
  * Emit domainChanged from bindtextdomain to trigger updates. (LP:
    #1220395)
  * Support TextArea used with an action.
  * Support option selector used with an action.
  * Add haptic feedback to AbstractButton. (LP: #1189537)

  [ Zsombor Egri ]
  * Fix Picker module deployment.
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Jussi Pakkanen ]
  * Adds thumbnailer image provider.

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Andrea Cimitan ]
  * Export a position value of the toolbar through dbus, setting the
    value of the dbus service created by the shell. (LP: #1224480)

  [ Guenter Schwann ]
  * Better handle the case of dismissing the OSK and focusing the text
    again fixes LP: #1228155. (LP: #1228155)

  [ Renato Araujo Oliveira Filho ]
  * Added "confirmRemoval" in ListItem.Empty This will ask for
    confirmation before remove the item. (LP: #1213046)
  * Disabled confirmation on swipe to delete as default.

  [ Leo Arias ]
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 786
 -- Ubuntu daily release <email address hidden> Mon, 07 Oct 2013 04:36:33 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 96, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+13.10.20131011-0ubuntu1

---------------
address-book-app (0.2+13.10.20131011-0ubuntu1) saucy; urgency=low

  [ Tiago Salem Herrmann ]
  * Use url decoding before using values. (LP: #1234234)

  [ Renato Araujo Oliveira Filho ]
  * Ask for confirmation during the contact removal. (LP: #1213046)
  * Removed trick to make the font gray when text does not have focus.
    (LP: #1228227)
  * Fixed save avatar function.
  * Initial implementation for UriHandler. (LP: #1230404)
  * Added preview image.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 101
 -- Ubuntu daily release <email address hidden> Fri, 11 Oct 2013 08:47:20 +0000

Changed in address-book-app (Ubuntu):
status: In Progress → Fix Released
Changed in address-book-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers