Automatically reveal toolbar when switching pages

Reported by Tim Peeters on 2013-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
High
Tim Peeters
Ubuntu UX
Critical
Vesa Rautiainen
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

The toolbar should automatically become visible when it has new buttons for the user.

After some time or after certain interactions, the toolbar must hide again. Additional feedback from design would be appreciated.

------------------------------
Desired resolution:

There is a design specification available for this feature here:
https://docs.google.com/a/canonical.com/document/d/1pIhxERCp355mI9SeA1M8W2vN4HVINEpEVCNx3y7ab4E/

Prototype: lp:~willow-team/willow/new-tabs-and-toolbar-interactions/

Related branches

lp:~tpeeters/ubuntu-ui-toolkit/toolbar-reveal
Merged into lp:ubuntu-ui-toolkit at revision 734
Zsombor Egri: Approve on 2013-09-02
PS Jenkins bot: Approve (continuous-integration) on 2013-09-02
lp:~tpeeters/ubuntu-ui-toolkit/toolbar-reveal2
Merged into lp:ubuntu-ui-toolkit at revision 805
Christian Dywan: Approve on 2013-10-22
PS Jenkins bot: Approve (continuous-integration) on 2013-10-21
Leo Arias (community): Needs Fixing (code review) on 2013-10-10
Tim Peeters (tpeeters) on 2013-08-01
Changed in ubuntu-ui-toolkit:
assignee: nobody → Tim Peeters (tpeeters)
status: New → Incomplete
importance: Undecided → Critical
John Lea (johnlea) on 2013-08-01
Changed in ubuntu-ux:
assignee: nobody → Vesa Rautiainen (vesar)
Vesa Rautiainen (vesar) on 2013-08-05
Changed in ubuntu-ux:
importance: Undecided → Critical
Vesa Rautiainen (vesar) wrote :

There is a design specification available for this feature here:
https://docs.google.com/a/canonical.com/document/d/1pIhxERCp355mI9SeA1M8W2vN4HVINEpEVCNx3y7ab4E/

Changed in ubuntu-ux:
status: New → Fix Committed
John Lea (johnlea) on 2013-08-07
description: updated
Tim Peeters (tpeeters) on 2013-08-20
Changed in ubuntu-ui-toolkit:
status: Incomplete → Confirmed
Tim Peeters (tpeeters) on 2013-08-21
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) on 2013-08-21
tags: added: toolbar
description: updated
Tim Peeters (tpeeters) on 2013-08-21
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Invalid
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130903.3-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130903.3-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Reverse cherrypicking rev734.

  [ Zsombor Egri ]
  * Branch 734 removed, causing Unity test failures.

  [ Nicolas d'Offay ]
  * Added ItemSelector. Extend OptionSelector and fixed various bugs.
    Added tests for both OptionSelector and ItemSelector. (LP: #1169258,
    #1218250, #1218247)

  [ tpeeters ]
  * New toolbar reveal/hide behavior, as specified by design. (LP:
    #1207369)

  [ <email address hidden> ]
  * This MP contains some fixes to autopilot test cases. Two test cases
    are commented for now as they were giving inconsistent results on
    phone. .

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 738
 -- Ubuntu daily release <email address hidden> Tue, 03 Sep 2013 11:46:19 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Invalid → Fix Released
Tim Peeters (tpeeters) on 2013-09-03
Changed in ubuntu-ui-toolkit:
status: Fix Committed → In Progress
Tim Peeters (tpeeters) on 2013-09-11
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Released → In Progress
Tim Peeters (tpeeters) on 2013-09-25
Changed in ubuntu-ui-toolkit:
importance: Critical → High
John Lea (johnlea) on 2013-10-04
tags: added: sabdfl-ux-requests
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) on 2013-10-22
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20131105.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20131105.1-0ubuntu1) trusty; urgency=low

  [ Albert Astals ]
  * Minor optimzations Add const & to foreach to save copies of
    "complex" types Remove initializations of QStrings to "" since they
    do nothing Return QString instead of "" since its faster Pass
    "complex" types as const & instead of copy to functions Not an
    optimization: Added const qualifier to two functions .

  [ Lars Uebernickel ]
  * Remove GIconProvider Use urls for file and data icons and the theme
    image provider (image://theme/) for themed icons.

  [ Kaleo ]
  * [visual design] Updated tabs chevron asset.

  [ Christian Dywan ]
  * Install translations for UI toolkit and gallery. (LP: #1239627)
  * Support checkbox used with an action.
  * Install autopilot modules in qmake not debian packaging.
  * Drop the $$ from system calls where output isn't needed.
  * Look for locale folder as per XDG basedir spec and rewrite test The
    new test case covers the whole range of changing languages, checking
    the strings from both QML and C++ and binding to a folder. (LP:
    #1175726, #1233071)
  * Define window within OrientationHelper to avoid a race condition.
    (LP: #1239760)

  [ Zsombor Egri ]
  * Support for taking themes from XDG_DATA_DIRS as well as from
    ~/.local/share. These paths are also added as import paths.
    UBUNTU_UI_TOOLKIT_THEMES_PATH overrules these import paths, and can
    have more than one path specified, each separated with column. (LP:
    #1221813)
  * Warnings treated as errors in all types of builds (debug or
    release). (LP: #1246290)
  * Introducing topmostItem property to drive whether InverseMouseArea
    should filter sensingArea events or to stay in the normal z-
    order/stack order of its parent. (LP: #1240460)

  [ Leo Arias ]
  * Added the go back method to the autopilot emulators. (LP: #1239751)
  * On the autopilot emulator, drag the toolbar to its full height. (LP:
    #1235060)
  * Initially show toolbar, but automatically hide after timeout. (LP:
    #1207369)
  * Added the change_state method to the CheckBox autopilot emulator.
    Cleaned up the autopilot gallery toggles tests.
  * Added the objectNames to the ComposerSheet buttons. (LP: #1244518)

  [ tpeeters ]
  * Update CrossFadeImage API so that sourceSize can be set by the
    applications. CHANGED in CrossFadeImage: readonly property size
    sourceSize TO property size sourceSize. (LP: #1227783)
  * Initially show toolbar, but automatically hide after timeout. (LP:
    #1207369)
  * Put tab bar in selection mode when apps are launched. (LP: #1223597)
  * Close tabbar and toolbar when user interacts with app contents. (LP:
    #1223604)

  [ Nicolas d'Offay ]
  * Added multiSelection bool and supporting code to OptionSelector and
    ItemSelector. This turns either component into a multiple choice
    selector. Fixed linked bugs. (LP: #1231936)

  [ Renato Araujo Oliveira Filho ]
  * Implemented emulator for swipe to remove. (LP: #1236464)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 820
 -- Ubu...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Tim Peeters (tpeeters) on 2013-11-07
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Sam Bull (dreamsorcerer) wrote :

What if it just bounced slightly into view during the transition? Much
like when you tap on the welcome screen, the dash or screen bounces into
view a little. It would keep it consistent with the discoverability of
these other features, and not get in the way after I've already learnt
that there is a toolbar on this or that page.

With the focus on content, I don't see why I should have this toolbar in
my face everytime I access a page, I'm going to have learnt the toolbar
exists here after the first 1 or 2 times it happens, and then it's just
going to keep doing it everytime anyway.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints