ToolbarButton can't be disabled

Bug #1202245 reported by Günter Schwann on 2013-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Critical
Tim Peeters
Unity Action API
Undecided
Antti Kaijanmäki
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

When setting "enabled" to false for a ToolBarButton, or it's Action the icon and text is grey.
But when clicking on it, onTriggered() is still called. So practically it's not disabled.

Related branches

Tim Peeters (tpeeters) on 2013-07-17
Changed in ubuntu-ui-toolkit:
assignee: nobody → Tim Peeters (tpeeters)
importance: Undecided → High
Tim Peeters (tpeeters) on 2013-07-19
Changed in ubuntu-ui-toolkit:
importance: High → Critical
Tim Peeters (tpeeters) on 2013-07-23
Changed in ubuntu-ui-toolkit:
status: New → In Progress
Tim Peeters (tpeeters) on 2013-08-07
Changed in unity-action-api:
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Antti Kaijanmäki (kaijanmaki) wrote :

Not a bug in unity-action-api, as the trigger() signal does check if the action is enabled before emitting signals. UITK most probablty calls triggered() instread of trigger() and thus bypasses the checks.

Changed in unity-action-api:
status: New → Opinion
status: Opinion → Invalid
Tim Peeters (tpeeters) wrote :

trigger() is in the latest unity-action-api code, but not in the package on saucy yet.

Changed in unity-action-api:
status: Invalid → Confirmed
status: Confirmed → Fix Committed
Antti Kaijanmäki (kaijanmaki) wrote :

No, trigger() has been there from the start.

Changed in unity-action-api:
status: Fix Committed → Invalid
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130822.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130822.1-0ubuntu1) saucy; urgency=low

  [ Alexandre Abreu ]
  * Add an actionmanager property that let clients be more flexible with
    their actions at runtime. (LP: #1207804)

  [ tpeeters ]
  * Do not trigger a ToolbarButton that is not enabled. (LP: #1202245)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 707
 -- Ubuntu daily release <email address hidden> Thu, 22 Aug 2013 18:55:49 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Tim Peeters (tpeeters) on 2013-08-30
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers