[SDK] Header tab should only display '>' when there is more than 1 tab

Reported by Christina Li on 2013-07-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
High
Tim Peeters
Ubuntu UX
Critical
Christina Li
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

When there's only tab, the header component don't need to display an arrow (>) next to the header.
The arrow should only be displayed when there is more than one tab.

Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → Critical
Changed in ubuntu-ui-toolkit:
importance: Undecided → High
assignee: nobody → Tim Peeters (tpeeters)
Changed in ubuntu-ux:
assignee: nobody → Christina Li (christina-li)
Tim Peeters (tpeeters) wrote :

Is there a use case? Why would you only have one tab?

Tim Peeters (tpeeters) on 2013-07-15
Changed in ubuntu-ui-toolkit:
status: New → Incomplete
Christina Li (christina-li) wrote :

Hi Tim,
Although I understand developers should mainly be using MainView when there's only one view, there are some situations where some apps may just have one tab due to content. For example, Selection view in the Gallery- there should be no chevron shown in the header; Weather app may only have one view (tab) because user has only selected to look at one location's forecast but later on they might add more locations.

We need to cater for these use cases.

Thanks

Tim Peeters (tpeeters) on 2013-07-22
Changed in ubuntu-ui-toolkit:
status: Incomplete → Confirmed
Tim Peeters (tpeeters) on 2013-07-24
tags: added: tabs
John Lea (johnlea) on 2013-08-08
Changed in ubuntu-ux:
status: Triaged → Fix Committed
Omer Akram (om26er) wrote :

Issue is fixed already.

Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers