Components should provide haptic feedback out of the box

Bug #1189537 reported by Christian Dywan on 2013-06-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Medium
Christian Dywan
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

QtMobility has an abstraction for hardware feedback like rumbling or vibrating when touching the screen or playing a sound. The basic components should support this out of the box, and if it makes sense provide some glue to customize it.
See http://doc-snapshot.qt-project.org/qt-mobility/qml-feedback-api.html
This is qtdeclarative5-qtfeedback-plugin for Qt5 and "import QtFeedback 5.0", the plugin name changed

Related branches

Christian Dywan (kalikiana) wrote :
description: updated
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
importance: Undecided → Medium
Christian Dywan (kalikiana) wrote :

Assessment of the status quo shows: we have the sound/ multimedia[1] part of QtFeedback but vibration[2] requires another hardware-specific module.

[1] https://qt.gitorious.org/qt/qtfeedback/blobs/master/src/plugins/feedback/mmk/qfeedback.cpp
[2] https://qt.gitorious.org/qt/qtfeedback/blobs/master/src/plugins/feedback/immersion/qfeedback.cpp

Thomas Voß (thomas-voss) wrote :

A short-term solution to access the vibrator is to do the equivalent of echo 150 > /sys/class/timed_output/vibrator/enable in the hardware-specific module.

Christian Dywan (kalikiana) wrote :

This isn't tested on a device. It provides a plugin that takes custom and themed vibrations, as used in the QML testcase. An open question is if it's preferrable to patch QtFeedback/ merge upstream or install it as part of other platform components, though I'm not sure if we have a suitable place for it.

Christian Dywan (kalikiana) wrote :

https://launchpad.net/~ubuntu-sdk-team/+archive/ppa/+builds?build_text=qtfeedback-mir&build_state=all now has test packages for saucy. The code in the branch enables vibration successfully.

Christian Dywan (kalikiana) wrote :

There's a separate bug 1214404 for integrating the QtFeedback plugin.

no longer affects: platform-api
Changed in ubuntu-ui-toolkit:
assignee: nobody → Christian Dywan (kalikiana)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Committed

The attachment "Patch against QtFeedback: "mir" backend using command line to vibrate (qmake mir_enabled=yes -r)" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20131007-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20131007-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * Add default tools (LP: #1233709). (LP: #1233709)

  [ Loïc Molinari ]
  * Added URI handler support.
  * Fixed UbuntuShape warnings when using a ShaderEffectSource as an
    image.

  [ <email address hidden> ]
  * Added test cases for text field testing.
  * Minor change to make the OptionSelector more testable by adding
    objectName property to uniquely identify the object. (LP: #1234020)

  [ Christian Dywan ]
  * Set offline storage path and add a unit test. (LP: #1231863)
  * Emit domainChanged from bindtextdomain to trigger updates. (LP:
    #1220395)
  * Support TextArea used with an action.
  * Support option selector used with an action.
  * Add haptic feedback to AbstractButton. (LP: #1189537)

  [ Zsombor Egri ]
  * Fix Picker module deployment.
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Jussi Pakkanen ]
  * Adds thumbnailer image provider.

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Andrea Cimitan ]
  * Export a position value of the toolbar through dbus, setting the
    value of the dbus service created by the shell. (LP: #1224480)

  [ Guenter Schwann ]
  * Better handle the case of dismissing the OSK and focusing the text
    again fixes LP: #1228155. (LP: #1228155)

  [ Renato Araujo Oliveira Filho ]
  * Added "confirmRemoval" in ListItem.Empty This will ask for
    confirmation before remove the item. (LP: #1213046)
  * Disabled confirmation on swipe to delete as default.

  [ Leo Arias ]
  * index property added to Tab to be able to reference the Tab number.
    Fixes bug #1233402. (LP: #1233402)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 786
 -- Ubuntu daily release <email address hidden> Mon, 07 Oct 2013 04:36:33 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints