Page stack header within a tab should be displayed instead of tabs

Reported by Calum Pringle on 2013-06-05
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Critical
Tim Peeters
Ubuntu UX
High
Calum Pringle
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

In cases where there is content which links to a page stack, e.g. a list item, within a view with tabs, the child view should have the header relevant to that view.

E.g. View has tabs, "Stuff >". tap on a list item reading "Sound" and the header on the child page will show "Sound". To get back to the tabs, press the back button and the header changes to the tabs.

Therefore you cannot switch between tabs until you are back at the root page.

Related branches

lp:~tpeeters/ubuntu-ui-toolkit/stack-tabs
Merged into lp:ubuntu-ui-toolkit at revision 649
PS Jenkins bot: Approve (continuous-integration) on 2013-07-25
Christian Dywan: Approve on 2013-07-22
Changed in ubuntu-ux:
importance: Undecided → High
assignee: nobody → Calum Pringle (calumpringle)
status: New → Confirmed
status: Confirmed → Fix Committed
Changed in ubuntu-ui-toolkit:
assignee: nobody → Tim Peeters (tpeeters)
Florian Boucault (fboucault) wrote :

I thought we would not combine flat navigation (tabs) with deep navigation (page stack) in the same view.
That's written at the bottom of:
http://design.ubuntu.com/apps/global-patterns/navigation

Calum Pringle (calumpringle) wrote :

Yes by that we meant not to have a back button and tabs on the same screen. I have updated the description here : http://design.ubuntu.com/apps/global-patterns/navigation

When we need to use deep navigation, for example when the user taps on a piece of content from a tabbed view, the header will update to represent the new view.

The page stack (deep navigation) introduces a back button which, when combined with tabs (flat navigation) in the same view, could be misinterpreted as another method for navigating between tabs.

Tim Peeters (tpeeters) on 2013-06-14
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Tim Peeters (tpeeters) on 2013-07-17
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) on 2013-07-18
Changed in ubuntu-ui-toolkit:
importance: High → Critical
Tim Peeters (tpeeters) on 2013-07-24
tags: added: tabs
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) on 2013-07-25
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130726.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130726.1-0ubuntu1) saucy; urgency=low

  [ Zoltán Balogh ]
  * The UI Toolkit has theme with artworks what should be under creative
    common license.

  [ Leo Arias ]
  * Renamed the UbuntuUiToolkit python package to ubuntuuitoolkit. (LP:
    #1204281)

  [ Juhapekka Piiroinen ]
  * Added Ubuntu Test module which contains UbuntuTestCase.
  * Use qmltestrunner for qml tests.
  * Adds missing dependency to devscripts which is required for the make
    license which uses licensecheck. (LP: #1205259)

  [ Luke Yelavich ]
  * Ship the components required for the calculator example.

  [ tpeeters ]
  * Allow combination of Tabs and PageStack: - Fix header behavior for
    Tabs inside PageStack - Add test for Tabs inside PageStack header
    bug - Replace deprecated components in PageStack tests - Add test
    program that combines PageStack and Tabs - Update Tabs
    documentation. (LP: #1187850)

  [ Christian Dywan ]
  * Refactor checklicense and include CSS files This also makes the test
    work on precise. (LP: #1195250)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 657
 -- Ubuntu daily release <email address hidden> Fri, 26 Jul 2013 12:23:40 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Joey Chan (qqworini) wrote :

Hi everyone,

I found this bug appear again, pls look at the clock app when click the "add city", both "tab" header and "page" header showed in the same place.

Also affects rss reader.

br,
Joey from rss reader team

Michael Spencer (mdspencer) wrote :

I get this too when I have a dark Suru gradient. Here is a very simple hack that fixes it - in the Tabs component, add this:

onVisibleChanged: tabBar.visible = visible

Tim Peeters (tpeeters) wrote :

what you are reporting now is a new bug. See https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1209403

Tim Peeters (tpeeters) on 2013-08-30
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

@tpeeters; hi, please do not change the status of bugs in the "ubuntu-ux" project, as we use this project to track design status and final design QA. For example, changing status from Fix Committed → Fix Released in ubuntu-ux means that a designer has tested the implementation of the bug on the phone and has confirmed that implementation matches the change request.

Full details of what status means for ubuntu-ux bugs is available at https://docs.google.com/a/canonical.com/document/d/1PcNRQZFbfmmQEvxu4SZHO3GZ9Zaetg9p2DOmRwOUbS0/edit#heading=h.yt7pgvf4mg7m

Reverting ubuntu-ux status back to Fix Committed so that designers know that the implementation is ready to test.

Changed in ubuntu-ux:
status: Fix Released → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers