[Toolbar] Bottom edge swipe is detected 2gu away from edge

Reported by Oren Horev on 2013-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Undecided
Tim Peeters
Ubuntu UX
Critical
Oren Horev
manhattan
High
Olivier Tilloy
webbrowser-app
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

currently I can grab the toolbar with an initial touch at more than 10GU away from the edge, a natural position to flick a web page.

This makes the bottom edge swipe conflict with scrolls

expected behaviour
-----------------
edge detection area shouldn't exceed the shell threshold of 2gu

Update
------
This issue is occurring across all apps. Seems that edge detection / toolbar triggering with a bottom edge swipe is not consistent with detection other behaviours of other edges

Related branches

lp:~osomon/webbrowser-app/sdk-generic-toolbar
Merged into lp:webbrowser-app at revision 124
Ugo Riboni: Approve on 2013-05-06
PS Jenkins bot: Approve (continuous-integration) on 2013-05-03
Oren Horev (oreneeshy) on 2013-02-20
description: updated
Oren Horev (oreneeshy) on 2013-02-20
summary: - [SDK] Bottom edge swipe is detected more than 10gu away from edge
+ [browser] Bottom edge swipe is detected more than 10gu away from edge
tags: removed: must-have
Michał Sawicz (saviq) on 2013-02-20
Changed in manhattan:
status: New → Confirmed

This is happening because the browser currently doesn’t use the SDK’s toolbar, it implements its custom solution.
This will change in the future. In the meantime, we need to ensure the trigger zone has the same height as in the SDK. That’s currently 2 grid units.

Olivier Tilloy (osomon) wrote :

Lowering the importance: while annoying, it’s not something that renders the app unusable. Definitely an issue to fix soon, but not a showstopper.

Changed in manhattan:
importance: Critical → High
Olivier Tilloy (osomon) wrote :

It looks like we could make use of the GenericToolbar type that’s in the SDK. Unfortunately at the moment it’s an internal type, meaning it’s not publicly exported.

Oren Horev (oreneeshy) wrote :

Though demoing today I had tripped on that one I agree it's not a show stopper :-)

I had a look at how we can fix that properly, and it appears it’s far from trivial.
The current custom implementation of the toolbar in the browser differs a lot from the one in the SDK. The GenericToolbar in the SDK is not publicly exposed, so we can’t use it. I tested copying the necessary components from the SDK and adapting the browser’s code to them, but it results in a huge diff, and broken interactions in many subtle ways.
This requires more work, and there’s no way we can fix it safely in time for the demo. Sorry.

summary: - [browser] Bottom edge swipe is detected more than 10gu away from edge
+ [browser] Bottom edge swipe is detected 8gu away from edge
Olivier Tilloy (osomon) on 2013-05-01
Changed in manhattan:
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

The SDK now exposes a generic Panel component, that the browser will use to replace its custom RevealingBar component.

Olivier Tilloy (osomon) on 2013-05-06
Changed in manhattan:
status: In Progress → Fix Committed
Olivier Tilloy (osomon) on 2013-05-09
Changed in manhattan:
status: Fix Committed → Fix Released
Oren Horev (oreneeshy) wrote :

reopened this bug as this i still happening on browser as well as all apps. i suspect it is a problem with the toolbar triggering - you can swipe the toolbar in even when starting the the edge swipe a few GU into the view.

Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Oren Horev (oreneeshy)
summary: - [browser] Bottom edge swipe is detected 8gu away from edge
+ [Toolbar] Bottom edge swipe is detected 8gu away from edge
description: updated
description: updated
Changed in ubuntu-ux:
importance: Undecided → Critical

Right, but is it really as bad as 8 gu away from the edge? If not, please file a new bug instead of re-opening this one.

Oren Horev (oreneeshy) wrote :

you are probably right it's only 2-3GUs but still off the edge significantly. Which project owns this bug? Unity8 or toolkit?

information type: Private → Public
Olivier Tilloy (osomon) wrote :

I’d say the UITK (ubuntu-ui-toolkit).

Olivier Tilloy (osomon) on 2013-10-14
Changed in webbrowser-app:
status: New → Invalid
Tim Peeters (tpeeters) wrote :

The "triggerSize" is 2 grid units, and this was done on purpose.

On a phone, less may work well, but on desktop the toolbar will become unusable. So I propose to fix this bug only in combination with fixing this one: https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1182734 where perhaps on desktop we should always have the toolbar active so that the users don't have to position the mouse cursor in the bottom few pixels of the application window?

Tim Peeters (tpeeters) wrote :

If the triggerSize of 2 GU is too large, this is a different bug from the original bug described here.
If the triggerSize needs to be changed, please open a new UITK bug for that. Note that we will first need a solution for opening the toolbar on desktop before reducing the triggerSize.

summary: - [Toolbar] Bottom edge swipe is detected 8gu away from edge
+ [Toolbar] Bottom edge swipe is detected 2gu away from edge
Changed in ubuntu-ux:
status: Fix Committed → Confirmed
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
status: Confirmed → Invalid
assignee: nobody → Tim Peeters (tpeeters)
Changed in ubuntu-ux:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers