Untranslated strings in Photoroll

Bug #1521222 reported by Richard Somlói on 2015-11-30
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu UI Toolkit Extras
High
Arthur Mello

Bug Description

current build number: 193
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en

There are some untranslated strings in the Camera apps's PhotoRoll. When you select Edit, the "Crop" action in untranslated, and when you want to revert the changes, the all strings of the dialog are in English, except "Cancel". These strings are not included in the .po file on Launchpad.

p.s.: These are translated if you edit the picture from the Gallery app.

Related branches

Richard Somlói (ricsipontaz) wrote :
Richard Somlói (ricsipontaz) wrote :
Sebastien Bacher (seb128) wrote :

The component is coming from ubuntu-ui-extras

affects: camera-app → ubuntu-ui-extras
Changed in ubuntu-ui-extras:
importance: Undecided → High
status: New → Confirmed
description: updated
Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → Confirmed
milestone: none → ww02-2016
assignee: nobody → Bill Filler (bfiller)
Bill Filler (bfiller) on 2015-12-15
Changed in ubuntu-ui-extras:
assignee: nobody → Arthur Mello (artmello)
Arthur Mello (artmello) on 2016-01-05
Changed in ubuntu-ui-extras:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Víctor R. Ruiz (vrruiz) wrote :

I don't think really fixed. The strings are in rc-proposed, but don't appear translated. I think it is because they need component should specify the domain "ubuntu-ui-extras" with i18n.dtr(), otherwise it will use the one set by the application.

Binary file share/locale-langpack/es/LC_MESSAGES/ubuntu-ui-extras.mo matches
lib/arm-linux-gnueabihf/qt5/qml/Ubuntu/Components/Extras/PhotoEditor.qml: title: i18n.tr("Revert to original")

Richard Somlói (ricsipontaz) wrote :

Yes, these strings are still untranslated on the latest rc-proposed build.

Víctor R. Ruiz (vrruiz) wrote :

I should review my pseudo-English before posting the texts ;) «I don't think [it is] really fixed». «I think it is because [the] component should specify the domain "ubuntu-ui-extras" with i18n.dtr()».

Richard Somlói (ricsipontaz) wrote :

It's still wrong in OTA-10. Could you fix it in OTA-11? :)

Changed in canonical-devices-system-image:
milestone: ww02-2016 → 11
status: Fix Released → Confirmed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
milestone: 11 → 12
tags: added: l10n zh
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Richard Somlói (ricsipontaz) wrote :

It's still English in the latest rc-proposed image, despite of it's fully translated:
https://translations.launchpad.net/ubuntu-ui-extras

Pat McGowan (pat-mcgowan) wrote :

Crop is translated but the revert dialog is not

Changed in canonical-devices-system-image:
milestone: 12 → 13
status: Fix Committed → Confirmed

This is still an issue with the latest rc-proposed iamge.

Víctor R. Ruiz (vrruiz) wrote :

I can confirm that Crop is now translated and that revert dialog shows in English, as Pat reports. The problem is that the domain is not set:

Ubuntu/Components/Extras/PhotoEditor.qml: title: i18n.tr("Revert to original")

Changed in canonical-devices-system-image:
milestone: 13 → backlog

Any update on this issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers