Trying to create a hardlink from another file system leads to crash Ubuntu Tweak

Bug #989511 reported by Stephan Müller on 2012-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Medium
Ding Zhou

Bug Description

It's obvious that creating a hard link from another file system doesn't work. I tried it anyway in a semblance of anawarness. Unfortunately UT crashed.

Ding Zhou (tualatrix) wrote :

Could you tell me the steps of how make UT crashed? So that I can try to reproduce.

Thanks.

Changed in ubuntu-tweak:
status: New → Incomplete
Stephan Müller (megandy) wrote :

I plugged in my external hard drive which is ext4 formated and tried to create a hard link to my home directory which is located locally. That was done with ubuntu 11.04.

Stephan Müller (megandy) wrote :

Sorry. To be more precise:
1. Plugged in my hd
2. chosen a file
3. used UT's script component to create a hard link to a dir located in my home dir.
4. crash

Ding Zhou (tualatrix) wrote :

OK. Thanks for your report.

The hardlink script could not create script cross device, I should add device check in the script.

Changed in ubuntu-tweak:
status: Incomplete → Confirmed
milestone: none → 0.8.0
assignee: nobody → Ding Zhou (tualatrix)
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers