Workspace Edge Settings stops working on reboot

Reported by wistle on 2012-04-17
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Medium
Ding Zhou

Bug Description

Everytime I reboot I have to reset the Workspace Edge Settings under Desktop -> Compiz Settings. After reboot the edges stop responding, but when I open Ubuntu Tweak the settings are still defined. I simply need to reselect them and it starts working again.
I'm running Ubuntu 12.04 (development) and Ubuntu Tweak 0.6.2. The problem appeared after a system update within the last two weeks. Not sure what files I can attach to help identify the problem.

Ding Zhou (tualatrix) wrote :

Thanks for your report.

Could you try to run "unity --replace" after you login to desktop?

Then check if workspace edge settings work. I guess this is an issue to unity.

Changed in ubuntu-tweak:
status: New → Incomplete

On 18/04/2012 10:06, Ding Zhou wrote:
> Thanks for your report.
>
> Could you try to run "unity --replace" after you login to desktop?
>
> Then check if workspace edge settings work. I guess this is an issue to
> unity.
>
> ** Changed in: ubuntu-tweak
> Status: New => Incomplete
>
Yes, this restores the functionality. Should I report this to Unity then?

Ding Zhou (tualatrix) wrote :

Yes. I think you should report this to Unity.

But first please update to the latest version of Unity.

gBug (gigalimit20) wrote :

This equally affects me too.

Trying "unity --replace" did not do the wonder after restarting... I have to 'Ubuntu-Tweak' the corners at every login. This is slightly inconvenient.
Is there a config that can be set manually? I believe the settings is being overwritten each session. I've searched gconf-tool/dconf-tool, no use.

PAINFUL! PAINFUL!!

wistle (charl-wentzel) wrote :

This bug is a duplicate of: 986208
A temporary fix was provided recently....

Quick fix, courtesy of Steven Kurylo (skurylo):

I used gconf-editor to change the following settings:

compiz-1> general> screen0> options> active_plugins

and I moved scale to the bottom of the list. Scale now works; however
expo didn't. I then moved expo to be below unityshell, but above scale.
It now works too.

Ding Zhou (tualatrix) wrote :

#5

thanks for the workaround. I'd like to add it to Ubuntu Tweak in the next version.

Changed in ubuntu-tweak:
status: Incomplete → Confirmed
milestone: none → 0.7.2
assignee: nobody → Ding Zhou (tualatrix)
importance: Undecided → Medium
gBug (gigalimit20) wrote :

+1 for #5

Just to confirm that that workaround worked for me too.

LM (l-moeller1) wrote :

#5:

The workaround works for me in a different way.
Moving scale to the bottom of the list works for me fine, too.
But expo doesn't work if it is above scale and below unityshell.

Expo has to be on the bottom of the list for me. Above of expo has to be scale.
Now it works fine for me, too.

I am running 0.7.2 on both a laptop and desktop running 64 bit precise but still have this problem.

Ding Zhou (tualatrix) on 2012-06-19
Changed in ubuntu-tweak:
milestone: 0.7.2 → 0.7.3
Ding Zhou (tualatrix) wrote :

I tried to add the workaround to Ubuntu Tweak, but it seems the Gconf binding with Gobject has no gconf_value_set_list() method, so I can't do plugins reorder to the key of "/apps/compiz-1/general/screen0/options/active_plugins".

So this bug won't fixed in Ubuntu Tweak, please wait for the upstream bug: #986208.

Changed in ubuntu-tweak:
status: Confirmed → Won't Fix
Tomaszy (wojownik-swiatla) wrote :

Hello! I've tried both settings: #5 & #8 :
in both expo works and persists logouts,
but "show desctop" function doesn't...

What can I do to make it permanent?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers