lightdm background does not show if not in /usr/share/backgrounds

Reported by Bruce Pieterse on 2011-11-09
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Medium
Ding Zhou

Bug Description

Hi,

Last week I changed the background using the Login Settings page to change the background for LightDM. Unfortunately, if the wallpaper is located in the users home directory, LightDM will just show a black background.

The work around for this is to copy the wallpaper to the /usr/share/backgrounds directory for LightDM and give it a name like loginscreen.{jpg,png} so that future updates to the background don't leave old wallpapers in the directory. Or that can be an option as well!?

Ding Zhou (tualatrix) wrote :

Hi, thank you for your report.

First, I have no problem with the background in my Home folder. Could you provide the the full path or image when you set for login background?

Changed in ubuntu-tweak:
status: New → Incomplete
Bruce Pieterse (octoquad) wrote :

Sure, I have updated the background, as I saw there was a new update for ubuntu-tweak. This is what I have for unity-greeter.conf:
[greeter]
background = /home/bruce/Library/Graphics/Wallpapers/1440x900/01649.jpg
...

The path is correct, as I have tested with eog /home/bruce/Library/Graphics/Wallpapers/1440x900/01649.jpg from the CLI.

However the error still persists.

While I was waiting for a response, I manually set up a background and I copied it into /usr/share/backgrounds and edited unity-greet.conf. One thing I did notice is that if the permissions are not set properly it will not work. You need at least go+r in order for the background to show. Any ideas?

Ding Zhou (tualatrix) wrote :

The permission of the background file at home is not set correctly, so it doesn't work. Right?

OK, I plan to add permission check feature.

Changed in ubuntu-tweak:
status: Incomplete → New
status: New → Confirmed
milestone: none → 0.6.0
importance: Undecided → Medium
assignee: nobody → Ding Zhou (tualatrix)
Bruce Pieterse (octoquad) wrote :

Ding,

I previously had file permissions at 0777 and I have now changed it to 0644 but I still can't get the background to show. I did some digging and found this in the lightdm logs:

[+2.53s] DEBUG: user-list.vala:158: Making background /home/bruce/Library/Graphics/Wallpapers/1440x900/_99.jpg at 1440x900
[+2.53s] DEBUG: user-list.vala:196: Error loading background: Failed to open file '/home/bruce/Library/Graphics/Wallpapers/1440x900/_99.jpg': Permission denied
[+2.53s] DEBUG: user-list.vala:1216: Rendered first frame
[+2.57s] DEBUG: user-list.vala:174: Render of background /home/bruce/Library/Graphics/Wallpapers/1440x900/_99.jpg at 1440x900 complete

Even if the file is owned by root:root like in /usr/share/backgrounds it still doesn't show.

Perhaps this is a lightdm bug then?

Ding Zhou (tualatrix) wrote :

It is not a lightdm bug, the log said "Permission denied".

Could you provide the output of "sudo ls -l /home/bruce/Library/Graphics/Wallpapers/1440x900/_99.jpg" to me?

Bruce Pieterse (octoquad) wrote :

shox ~ » sudo ls -l /home/bruce/Library/Graphics/Wallpapers/1440x900/_99.jpg
-rw-r--r--. 1 bruce bruce 342559 2009-04-24 14:48 /home/bruce/Library/Graphics/Wallpapers/1440x900/_99.jpg

Wieke Kanters (kantersw) wrote :

Hi

I think I was having a similar problem. After reading this bug report I decided to check the permissions of the images I had tried to use and it turned out that the permission for "others" was set to "none". So only the owner (either me or root for the images in question) was allowed read/write access. I turned the permission for "others" to "read-only" and now it works.

Paddy Landau (paddy-landau) wrote :

I have found a further problem to this.

If your home folder is encrypted, you cannot even log in!

See thread:
http://ubuntuforums.org/showthread.php?t=1973961

A Brainstorm was raised some time ago to set the login wallpaper the same as the user's wallpaper, but this was discussed as a bad idea, because:
(1) what happens in a multi-user environment?
(2) what if the user uses a personal wallpaper, e.g. a family shot, that should not be on the login wallpaper?
(Unfortunately I cannot find that Brainstorm again.)

To resolve the various problems, simply revert to using a default wallpaper for the login screen, and allow the administrator to change it only to a wallpaper accessible to root without any logins.

M Henri Day (mhenriday) wrote :

It would seem that the «solution» to the problems with the login wallpaper has been to remove the ability to tweak login settings that was found in, e g, version 0.7.0-1~precise4 ; in the current version (0.7.1-1~precise1) the heading «Startup» under the «Tweaks» tab is no longer found. Quite frankly, I found the previous version far more useful....

Henri

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers