Update manager shows locked application for upgrade

Bug #792715 reported by aproposnix on 2011-06-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Medium
Unassigned

Bug Description

In synaptic, I have locked the version of an application from being upgraded (the newer version of this app is VERY buggy). I would expect that UT would respect this lock and not offer it as an upgrade.

The issue here is that when i have many upgrades, I have to scroll through them all to identify what should not be upgraded.

Another option is to add the ability to not offer to upgrade from UT (that way the user doesn't even have to lock it through synaptic)

Ding Zhou (tualatrix) wrote :

Does the version lock affect with apt-get update?

aproposnix (rimez) wrote :

No it doesn't out-of-box. However, I do think it's possible to pin apps with apt. Have a look at this:
http://jaqque.sbih.org/kplug/apt-pinning.html

Ding Zhou (tualatrix) wrote :

OK, thanks for sharing the cool "apt-pinning", but I can't fix this problem because it's not related to Ubuntu Tweak.

Changed in ubuntu-tweak:
status: New → Won't Fix
aproposnix (rimez) wrote :

Actually, I was wrong in the first response to you. If I use synaptic to lock a version, it seems that the system update menu>system>administration>update manager DOES respect the lock. Additionally, running apt-get update does not offer to upgrade the locked version (or make it appear in update manager).

here's a screenshot to help you better understand: http://goo.gl/a42qb

The only place where the locked version appears is through UT.

I respect your decision but as a user, I would still expect UT to not offer to upgrade the app.

aproposnix (rimez) wrote :

Here's another screenshot showing that when you click on "refresh" in UT, it's getting the permission to use Synaptic package mannager (which has the version of the application pinned). When it refreshes it still shows the locked version.

http://goo.gl/JqLBn

Ding Zhou (tualatrix) wrote :

Sorry, I can't see the screenshot.

Could you attach it here?

Changed in ubuntu-tweak:
status: Won't Fix → New
aproposnix (rimez) wrote :

No Problem. Here you go.

Ding Zhou (tualatrix) wrote :

Thanks. Bug confirmed!

Changed in ubuntu-tweak:
status: New → Confirmed
milestone: none → 0.6.0
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers