ubuntu tweak crashes on start up with Error: unsupported locale setting

Reported by ondro89 on 2010-04-30
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Low
Ding Zhou

Bug Description

Traceback (most recent call last):
  File "/usr/bin/ubuntu-tweak", line 109, in <module>
    from ubuntutweak.mainwindow import MainWindow
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 142, in <module>
    MLOADER = ModuleLoader(modules.__path__[0])
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/__init__.py", line 27, in __init__
    package = __import__('.'.join([__name__, module]), fromlist=['modules'])
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/compiz.py", line 63, in <module>
    class CompizSetting:
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/compiz.py", line 64, in CompizSetting
    if module_check.has_ccm() and module_check.has_right_compiz():
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/common/systeminfo.py", line 77, in has_ccm
    import ccm
  File "/usr/lib/python2.6/dist-packages/ccm/__init__.py", line 1, in <module>
    from ccm.Conflicts import *
  File "/usr/lib/python2.6/dist-packages/ccm/Conflicts.py", line 27, in <module>
    from ccm.Constants import *
  File "/usr/lib/python2.6/dist-packages/ccm/Constants.py", line 88, in <module>
    locale.setlocale(locale.LC_ALL, "")
  File "/usr/lib/python2.6/locale.py", line 513, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting

Ding Zhou (tualatrix) wrote :

You should first install the language pack in "Language Support".

Ding Zhou (tualatrix) on 2010-05-02
Changed in ubuntu-tweak:
milestone: none → 0.5.5
assignee: nobody → TualatriX (tualatrix)
importance: Undecided → Low
status: New → Confirmed
summary: - ubuntu tweak crashes on start up
+ ubuntu tweak crashes on start up with Error: unsupported locale setting
Ding Zhou (tualatrix) on 2010-05-02
Changed in ubuntu-tweak:
status: Confirmed → Fix Committed
ondro89 (ondro89) wrote :

I had som problems with locales(something with LC_ALL), so I reinstaled ubuntu, then I have installed localization. Now Ubuntu tweak works fine. But I think that it should work no matter what language I use because english is installed by default and I think it shoul use english instead of my local language.

Changed in ubuntu-tweak:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Valter Rescic (valter-rescic) wrote :

I installed the language pack and the latest version of Tweak but the application still crashes. This is the message:

Traceback (most recent call last):
  File "/usr/bin/ubuntu-tweak", line 109, in <module>
    from ubuntutweak.mainwindow import MainWindow
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 142, in <module>
    MLOADER = ModuleLoader(modules.__path__[0])
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/__init__.py", line 27, in __init__
    package = __import__('.'.join([__name__, module]), fromlist=['modules'])
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/shortcuts.py", line 32, in <module>
    from compiz import CompizSetting
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/compiz.py", line 63, in <module>
    class CompizSetting:
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/compiz.py", line 64, in CompizSetting
    if module_check.has_ccm() and module_check.has_right_compiz():
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/common/systeminfo.py", line 77, in has_ccm
    import ccm
  File "/usr/lib/python2.6/dist-packages/ccm/__init__.py", line 1, in <module>
    from ccm.Conflicts import *
  File "/usr/lib/python2.6/dist-packages/ccm/Conflicts.py", line 27, in <module>
    from ccm.Constants import *
  File "/usr/lib/python2.6/dist-packages/ccm/Constants.py", line 88, in <module>
    locale.setlocale(locale.LC_ALL, "")
  File "/usr/lib/python2.6/locale.py", line 513, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting

Valter Rescic (valter-rescic) wrote :

The latest version was still 0.5.4

asfr6@yahoo.fr (asfr6) wrote :

i install the language pack in "Language Support". the bug is fix. Thx

Ding Zhou (tualatrix) on 2010-05-04
Changed in ubuntu-tweak:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers