Install via commandline failed

Bug #513764 reported by Karel Zimmer on 2010-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
High
Ding Zhou

Bug Description

Hi try to install Ubuntun Tweak via command line, pls sewe the output:
karel@PC06:~$ sudo add-apt-repository ppa:tualatrix/ubuntu-tweak
[sudo] password for karel:
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 60, in run
    self.add_ppa_signing_key(self.ppa_path)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 79, in add_ppa_signing_key
    '\"signing_key_fingerprint\": \"(\w*)\"', lp_page)[0]
IndexError: list index out of range

Both on i386 and AMD64.

Ding Zhou (tualatrix) wrote :

You got a wrong PPA url.

It's "ppa:tualatrix/ppa", not "ppa:tualatrix/ubuntu-tweak"

Try

sudo add-apt-repository ppa:tualatrix/ppa

Ding Zhou (tualatrix) wrote :

Sorry, I've made the mistake on the website, Now it has been fixed.

http://ubuntu-tweak.com/downloads/

Karel Zimmer (karelz) wrote :

Aha,
i used other which worked (like ppa:yorba/ppa).
I tried the new PPA and it works,
Thanks!

Bug can be closed, if you agree of course.

Ding Zhou (tualatrix) on 2010-01-28
Changed in ubuntu-tweak:
status: New → Fix Released
milestone: none → development-snapshot
assignee: nobody → TualatriX (tualatrix)
importance: Undecided → High
Karel Zimmer (karelz) wrote :

The website still says:
Go to System / Administration / Software Sources, click on Other Software tab, click Add button, and enter “ppa:tualatrix/ubuntu-tweak”.

Is that OK?
Should that not read "ppa:tualatrix/ppa" too?
Both seem to work....

Ding Zhou (tualatrix) wrote :

OH.

Yes!!! it sould be "ppa:tualatrix/ppa" too, Thanks for your remind.

Karel Zimmer (karelz) wrote :

OK, you're welcome.
Thanks for your fast response.

Ubuntu Tweak rocks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers