Ubuntu tweak doesn't recognize the desktop environment

Bug #447966 reported by Kels on 2009-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Medium
Ding Zhou

Bug Description

After installation and a couple of tweaks performed on my system (Karmic beta, all updates; kde 4.3.2 + Gnome) in kde (where it rightly says some functions are only supported under gnome), I logged in to the gnome desktop but it still gives the same message now. Doesn't realize it's in Gnome any more, still thinks it's kde. If it means anything this was a Kubuntu Jaunty system originally, upgraded to Karmic online.

Ding Zhou (tualatrix) wrote :

Maybe you're still using KDM to login the GNOME Desktop?

Kels (echukwuogor) wrote :

Aha! That must be the problem. Point taken. Will try with gdm.

Kels (echukwuogor) wrote :

Works well with gdm, not so with kdm. Can you do anything about this?

Ding Zhou (tualatrix) wrote :

Thanks, I will improve the desktop environment determine method.

Changed in ubuntu-tweak:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 0.5.0
assignee: nobody → TualatriX (tualatrix)
lepoulpe303 (lepoulpe303) wrote :

I have same issue :

Ubuntu 8.10 64 bits
(only Gnome installed)
Ubuntu Tweak 0.4.9.1

Thus Gnome is detected in General Tab.

(see attachments)

Ding Zhou (tualatrix) on 2009-11-28
Changed in ubuntu-tweak:
status: Confirmed → Fix Committed
Sayantan Das (sayantan13) wrote :

Hi,

I have the same problem with Linux Mint 8. It does not let me add 3rd party softwares, neither does it open the application installation page. It gives an error desktop environment not recognised

Thanks,

Sayantan Das (sayantan13) wrote :

Hi ,
To be exact, the error says, This feature isn't currently available in your distribution.
I'm using Linux Mint 8 x64 RC

Ding Zhou (tualatrix) wrote :

Thanks for your report. It will be fixed in 0.5.0.

Not sure if this is related but I have a similar problem when I log in remotely using NX (nomachine).
When running ubuntu-tweak on the remote machine it says for some pages: "This feature is currently only available in GNOME Desktop Environment". When logged in locally it gives me no errors.
Both client and remote PC run Ubuntu 9.10 (Karmic) with only gdm/gnome present.

Ding Zhou (tualatrix) on 2010-01-10
Changed in ubuntu-tweak:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers