Janitor preparation to remove kernels results in crash of Ubuntu Tweak

Bug #1051717 reported by boskysquelch on 2012-09-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
High
Ding Zhou

Bug Description

Whilst using Ubuntu Tweak whenever I ask to examine kernels to remove the program will crash.Whether by typical use eg

please see first block of text in file attached

or by choosing to look at the kernels as a final choice of preparation.

please see second block of text in file attached

I have removed_reinstalled via USC

Problem continues. I am using Kernel Linux 3.6.0-030600rc3-generic.<<< requested by bug report to Launchpad of a Logitech mouse problem.

I would be happy to go back to current kernel if required.And would welcome any suggestions or instructions.

boskysquelch (boskysquelch) wrote :

file applicable to comments above : ubuntu-tweak -d output

Ding Zhou (tualatrix) wrote :

Have you changed the theme of Ubuntu?

boskysquelch (boskysquelch) wrote :

@Ding Zhou.

I may have changed Theme and then changed it back again to ambiance, as it is now.

I did choose to keep a different icon set. I just changed them and the result was the same.

Are you referring to the GTK & Pango references?

Is Pango the culprit maybe?

Please advise on how to proceed.

*the only thing directly related to Pango that I can think I recently install was the upgrade of Firefox 15 &/or a program called Cuttlefish.
I also recently installed a alarm program called MyWake.
Have been tweaking GIMP to install 'LAB Analysis', a forensic colour tool.
I also played with Thunar, Catfish.
I installed Phatch & Shutter.

Is there a log for the above additions to the system which I could provide?

Ultimately I am prepared to do a complete re-installation of 12.04 if required.

Thank-you for your time.

boskysquelch (boskysquelch) wrote :

Via use of MyUnity, as confirmed by Ubuntu Tweak, I have restored my Themes setting back to default(Ambiance, ubuntu-dark-mono) and the issue still occurs.ie the program crashes whilst looking for Old Kernels.

I then went to try ubuntu-tweak-d and was given only this in response.

[Launcher][DEBUG] Distribution: Ubuntu 12.04 precise
Application: Ubuntu Tweak 0.7.3-1~precise1
Desktop:ubuntu (ubuntu-tweak:68)

then after trying to use Ubuntu Tweak a couple of times more, with the crashes still occuring I then got the output escalated to what can be seen in the ubuntu-tweak-doutputwithdefaulttheme.txt provided.

boskysquelch (boskysquelch) wrote :

more info

boskysquelch (boskysquelch) wrote :

UPDATE

Today I ran UbuntuTweak.

 In Janitor mode I chose to do everything but Old Kernel Removal until last.

Cleaning went smoothly until that.

As has been usual UbuntuTweak crashed, an apport report was prepared.

And as has been usual that could not/would not upload..with the usual dialogue saying that this report cannot be sent and the advice to remove Third Party Applications.

I then ran "ubuntu-tweak -d" .. this time UbuntuTweak did NOT crash.

However a no-entry symbol(circle filled in with red with a white horizontal bar) appeared alongside where there would usually be the Kernel references that would be ordinarily available to clear.

Please find attached the "ubuntu-tweak -d" output in txt file.

boskysquelch (boskysquelch) wrote :

ubuntu-tweak -d output file made on 30/10/12

Ding Zhou (tualatrix) on 2012-09-30
Changed in ubuntu-tweak:
milestone: none → 0.8.0
importance: Undecided → High
assignee: nobody → Ding Zhou (tualatrix)
status: New → Fix Committed
Ding Zhou (tualatrix) wrote :

Hello all,

Could you help to verify if this version is working? Thanks

boskysquelch (boskysquelch) wrote :

Thank-you very much indeed.

I can verify that the .deb successfully ran an Upgrade via USC . Furthermore Old Kernels were successfully removed.

A Crash Report did throw up again. But this may have been a hangover from a session yesterday, as it didn't run it's usual course. The gathering of info dialogue did not appear. UbuntuTweak cleanly relaunched and cleanly closed after running Janitor yet again to remove Kernel config files.

Thanks again for an excellent tool and for the fix supplied.

Please feel free to Close bug. :)

Ding Zhou (tualatrix) on 2012-10-10
Changed in ubuntu-tweak:
status: Fix Committed → Fix Released
Mark Dwyer (mdwy62) wrote :

Hi There. I cannot seem to clean old kernels via ubuntu-tweak either. I will attach the debug file. I don't think I am creating the debug file properly. All the output is still going to the terminal. I will reread the earlier posts and see if I can figure it out.

ubuntu-tweak -d > file.txt just saves:

Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no

Thanks.

Mark Dwyer (mdwy62) wrote :

I am using 12.04 ubuntu with gnome shell (not unity). Synaptic reports that I have ubuntu-tweak 0.8.6-1~precise1 installed. I tried reinstalling. Ok I used script filename.txt and then ran ubuntu-tweak -d in a terminal, then typed "exit" and got a log.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers