Error in workarounds: Fix the appearance of themes when granted root privileges

Bug #1016116 reported by Seria on 2012-06-21
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Low
Ding Zhou

Bug Description

(ubuntu-tweak:6527): GConf-WARNING **: : You can't use a GConfEngine that has an active GConfClient wrapper object. Use GConfClient API instead.

(ubuntu-tweak:6527): GConf-WARNING **: : You can't use a GConfEngine that has an active GConfClient wrapper object. Use GConfClient API instead.
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : default
Adding plugins
Initializing core options...done
[Workarounds][ERROR] org.freedesktop.DBus.Python.OSError: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.7/dist-packages/ubuntutweak/backends/daemon.py", line 415, in link_file
    os.symlink(src, dst)
OSError: [Errno 17] File exists
 (workarounds.py:75)

Ding Zhou (tualatrix) wrote :

Could you please give me the version of Ubuntu Tweak?

Changed in ubuntu-tweak:
status: New → Incomplete
Seria (andreas-boettger) wrote :

0.7.3

Ding Zhou (tualatrix) on 2012-06-25
Changed in ubuntu-tweak:
status: Incomplete → Confirmed
milestone: none → 0.7.3
assignee: nobody → Ding Zhou (tualatrix)
importance: Undecided → Low
Sos Oganessian (sos-u) wrote :

Is there a way to patch the effects of this bug? I tried to apply this setting thinking I could revert it, but this bug is not allowing that. The side effect being that whenever I let my system auto log me in it break the system theme>

Ding Zhou (tualatrix) wrote :

Could you run these two commands under terminal then give me the output? Thanks.

    sudo ls -l /root/.themes
    sudo ls -l /root/.icons

And I guess your current user is not root, right?

Ding Zhou (tualatrix) on 2012-08-03
Changed in ubuntu-tweak:
status: Confirmed → Incomplete
Ding Zhou (tualatrix) on 2012-08-20
Changed in ubuntu-tweak:
milestone: 0.7.3 → 0.8.0
status: Incomplete → Confirmed
Ren (ren-covey) wrote :

I'm having this error, too. I'm using Ubuntu 12.04 and Ubuntu Tweak 0.8.4

I used to use this workaround just fine. Yesterday I switched it off and then tried to switch it back on again and it won't now. I had just made changes to the file permissions in my main account, so I thought this must be it and tried changing it back. But it still won't work.I tried purging and re-installing, nothing changes.

Is there any fix for this? Now, even saving themes in the usr/share file does not fix the appearance issue. =(

Ding Zhou (tualatrix) on 2013-02-01
Changed in ubuntu-tweak:
milestone: 0.8.0 → 0.8.4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers