part of fsck error message is rendered offscreen during startup

Bug #945517 reported by Csipak Attila on 2012-03-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
mountall (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu release: Ubuntu 10.04.4 LTS
plymouth version: 0.8.2-2ubuntu2.2

On bootup, I received the Hungarian equivalent of the following error / prompt text:

"Errors were found while checking the disk drive for /
Press F to attempt to fix the errors, I to ignore, S to skip mounting or M for manual recovery"

Now the big problem was that the second line of the above text is significantly longer in the Hungarian translation, so "Press F to" and "recovery" were clipped off on the left and right side of the screen. Which left me really clueless about which button I should press to attempt fixing the error. In the end I successfully googled up the above English equivalent of the message to get the answer, but this is certainly not an example of good usability...

So either the loading screen should be able to render similar messages with automatic line breaks or (less elegant solution) someone should put linebreaks manually into all message texts. (I mean: into the original English messages. because, I guess, translators won't start to put any linebreaks when their translation doubles the character count of a single line.)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.2-2ubuntu2.2
ProcVersionSignature: Ubuntu 2.6.32-38.83-generic-pae 2.6.32.52+drm33.21
Uname: Linux 2.6.32-38-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
CheckboxSubmission: cd3a081d71b0fa03e8879dff272e423d
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Sat Mar 3 11:54:35 2012
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Gigabyte Technology Co., Ltd. P41T-D3
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-38-generic-pae root=UUID=33a8cb8e-2586-4bf1-a90f-7edaf6aa5b01 ro quiet splash
ProcEnviron:
 LANGUAGE=hu_HU:en
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VGA16 VGA
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 05/31/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F1
dmi.board.name: P41T-D3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF1:bd05/31/2010:svnGigabyteTechnologyCo.,Ltd.:pnP41T-D3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP41T-D3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P41T-D3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Csipak Attila (corphicks) wrote :
Gabor Kelemen (kelemeng) wrote :

Those are from mountall, reassigning.

affects: plymouth (Ubuntu) → mountall (Ubuntu)
Changed in mountall (Ubuntu):
status: New → Confirmed
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
todaioan (alan-ar06) on 2012-12-04
Changed in ubuntu-translations:
status: Triaged → Fix Committed
Changed in mountall (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

There certainly hasn't been a fix for this in mountall.

Changed in mountall (Ubuntu):
status: Fix Released → Triaged
Changed in mountall (Ubuntu):
status: Triaged → Fix Committed
Steve Langasek (vorlon) on 2013-01-02
Changed in mountall (Ubuntu):
status: Fix Committed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers