nm-applet translation template is obsolete

Bug #879017 reported by Gabor Kelemen on 2011-10-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
network-manager-applet (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

The nm-applet contains some strings that are marked for translation, but not present in the template.

The string on the attached screenshot comes from:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/network-manager-applet/oneiric/view/head:/debian/patches/lp341684_device_sensitive_disconnect_notify.patch

A simple intltool-update puts this into the template:
$ intltool-update -p
gabor@gabor-VirtualBox:~/checkout/ubuntu/network-manager-applet/po$ grep -r "Modem network" *
nm-applet.pot:msgid "Modem network"
gabor@gabor-VirtualBox:~/checkout/ubuntu/network-manager-applet/po$ msgfmt --stat nm-applet.pot
0 translated messages, 542 untranslated messages.

Note that currently the nm-applet template in Oneiric contains 530 strings.

Gabor Kelemen (kelemeng) wrote :
tags: added: needs-pot-on-build
Gabor Kelemen (kelemeng) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Gabor Kelemen (kelemeng) wrote :

In theory, this should do the trick, but I'm currently unable to test it because the package fails to compile.

tags: added: patch

The attachment "Build with translations" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Thanks, I'll add it in the coming update :)

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.2.0+git.20120126t000800.5151959-0ubuntu1

---------------
network-manager-applet (0.9.2.0+git.20120126t000800.5151959-0ubuntu1) precise; urgency=low

  [ Mathieu Trudel-Lapierre ]
  * upstream snapshot 2012-01-26 00:08:00 (GMT)
    + 515195990c5b36171d30cdd9e62c76f117f25c7e
  * debian/rules, debian/control: use dh-translations to make sure we get an
    updated translation template. Thanks to Gabor Kelemen for the patch.
    (LP: #879017)
  * debian/patches/vpn-import-export-dir.patch: dropped, applied upstream.
  * debian/patches/lp337960_dxteam_notification_icon_names.diff: refreshed.
  * debian/patches/lp912150_lazy_notify_init.patch: refreshed.
  * debian/patches/no_Werror.patch: drop changes to configure, which aren't
    needed since we use autoreconf.
  * debian/patches/nm-applet-use-indicator.patch: rework to avoid "flashing"
    every time the menu is opened. We're back to updating when AP, devices,
    etc. change and when new VPN connections are added, which should cover
    most cases. (LP: #823955)

  [ Luke Yelavich ]
  * Present wireless network strength and security status for wireless networks
    to screen reader users.
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 06 Feb 2012 12:08:33 -0500

Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Released
Gabor Kelemen (kelemeng) on 2012-02-07
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers