Unity: Long strings are not displayed properly in Dash

Reported by Andrej Znidarsic on 2011-03-09
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Ubuntu Translations
Medium
Unassigned
Unity
Undecided
Unassigned
unity-2d
High
Unassigned
unity-2d (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

As can be seen in the screenshot below if the string is too long three dots (...) are displayed in front of the word.

Can maximum length of the string be somehow increased?

Changed in unity-2d:
status: New → Confirmed
milestone: none → 3.8

El dc 09 de 03 de 2011 a les 21:09 +0000, en/na Andrej Znidarsic va
escriure:
> ** Attachment added: "zaslonska_slika.png"
> https://bugs.launchpad.net/bugs/732261/+attachment/1897381/+files/zaslonska_slika.png
>
> ** Also affects: ubuntu-translations
> Importance: Undecided
> Status: New
>

Does this have anything to do with bug 632526 perhaps?

 affects ubuntu-translations
 importance medium
 status triaged

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Changed in ubuntu-translations:
importance: Undecided → Medium
status: New → Triaged

David: same thing, but this looks terrible in Hungarian too: http://noob.hu/2011/03/09/1_2.png

Alex Launi (alexlauni) on 2011-03-10
Changed in unity:
status: New → Incomplete
tags: added: needs-design
GTriderXC (gtriderxc) wrote :

In Polish we're unable to understand the strings at all. The most important part is dotted. The description should have more lines. The line doesn't have to be longer itself.

http://www.marcus.org.pl/GTriderXC/annspc/5.png

Same problem with Brazilian Portuguese translation.

Changed in unity-2d:
importance: Undecided → High
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity-2d:
milestone: 3.8 → 3.10
Doctor (zoidbergdoctor) wrote :

In Czech it looks bad too. This text with dots are incomprehensible.

tags: added: i18n
Changed in unity-2d:
milestone: 3.10 → none
Stefan Löffler (st.loeffler) wrote :

I experience a bug with the same description "Long strings are not displayed properly in Dash (l10n)", albeit different symptoms - see the attached screenshots (this is unity2d, German locale).
In the unhighlighted case, the program label is simply truncated (the full label should be "Pidgin Internet-Sofortnachrichtendienst", while in the highlighted case the correct label is given, but the highlighting rectangle is too small.

Stefan Löffler (st.loeffler) wrote :
Olivier Tilloy (osomon) wrote :

Stefan: I believe what you are observing is a temporary partial solution to the original issue. It’s not much better though, and still needs fixing.

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Hendrik Knackstedt (hennekn) wrote :

Marking unity-2d as invalid since it got discontinued.

summary: - Long strings are not displayed properly in Dash (l10n)
+ Unity: Long strings are not displayed properly in Dash
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
Hendrik Knackstedt (hennekn) wrote :

Still an issue in Unity in Precise.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in unity-2d (Ubuntu):
importance: Undecided → Low
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers