Make the release announcement translatable

Bug #572919 reported by Dorian on 2010-05-01
76
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Gabor Kelemen
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

The Ubuntu changelog is in english and seems do be untranslatable.

1) Use an Ubuntu version that can be upgraded (Jaunty, Karmic, …).
2) Open "Update manager".
3) Do a distribution upgrade.
4) See the changelog in english.

I'm french (and it's the same for others languages), so the message should be in french :) .

Eleanor Chen (chenyueg) wrote :

The same for Chinese, we'd like to see it's translatable.

Dorian (ikolpm) wrote :

Yes, and for all the languages I think ;)

summary: - Translate the ubuntu changelog in French
+ Translatable ubuntu changelog
description: updated

This seems to be a question rather than a bug, converting this to a question?

Changed in ubuntu-translations:
status: New → Invalid
Gabor Kelemen (kelemeng) wrote :

Reopening, this is not a question. The text is not translatable at all, so we need to make it translatable.

Changed in ubuntu-translations:
status: Invalid → Confirmed
David Planella (dpm) wrote :

Dorian,

Thanks for reporting this bug.

In order for anyone to start working on a fix, it would be really useful if the description would be more detailed.

Do you think you could write down the steps you followed to reproduce this? Which changelog are you referring to? Which program shows this changelog? A screenshot would also be helpful.

Thanks!

Changed in ubuntu-translations:
status: Confirmed → Incomplete
David Planella (dpm) wrote :

The issue reported is a genuine bug, not a question, thus converting it back to a bug.

Dorian (ikolpm) on 2010-08-26
description: updated
Gabor Kelemen (kelemeng) wrote :

David: this is about the Release notes, shown after you click the Upgrade button in update-manager, next to the "New Ubuntu release 'x.y' is available" text:

= Welcome to the Ubuntu 'Maverick Meerkat' development release =

***
This is still a ALPHA release.
Do not install it on production machines.
***

Thanks for your interest in this development release of Ubuntu.
The Ubuntu developers are moving very quickly to bring you the
absolute latest and greatest software the Open Source Community has to
offer. This development release brings you a taste of the newest features
for the next version of Ubuntu.

<and a lot more, snip>

Gabor Kelemen (kelemeng) wrote :
Changed in ubuntu-translations:
status: Incomplete → Confirmed
Changed in update-manager (Ubuntu):
status: New → Confirmed
David Planella (dpm) wrote :

Thanks Gabor for the clarification.

One thing I can think of is to convert that file to a python module, assign the text to a variable and mark it for translation.

Dorian (ikolpm) on 2010-08-26
description: updated
David Planella (dpm) on 2010-08-27
Changed in ubuntu-translations:
status: Confirmed → Triaged
importance: Undecided → Medium
summary: - Translatable ubuntu changelog
+ Make the Ubuntu Release update-manager changelog translatable
Gabor Kelemen (kelemeng) on 2013-01-01
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Gabor Kelemen (kelemeng) on 2013-01-01
summary: - Make the Ubuntu Release update-manager changelog translatable
+ Make the Ubuntu-release-updater changelog translatable
Changed in ubuntu-translations:
assignee: nobody → Gabor Kelemen (kelemeng)

I'm fairly certain this is all sorted out now.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Released
Gabor Kelemen (kelemeng) wrote :

This one? I'd be surprised, maybe you were thinking of another, like bug #1094777?

Redmar (redmar) wrote :

I can confirm that the upgrade dialog for 12.10 to 13.04 still is fully English, and there seems to be no way to translate it. I've taken a quick look at the code, and it's not clear there has been any work to try and support localisation of the changelog. Why has this been marked as fix released?

Thibault D (thibdrev) wrote :

Yup, this bug is still here : I've seen this awful English message once again ! :)

David Planella (dpm) on 2013-04-30
Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
summary: - Make the Ubuntu-release-updater changelog translatable
+ Make the release announcement translatable
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers