default chinese font isn't ttf-wqy-microhei

Reported by Yunkwan on 2010-04-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Ubuntu Simplified Chinese Translators
fontconfig (Ubuntu)
Undecided
Unassigned
language-selector (Ubuntu)
Undecided
Unassigned
language-support-fonts-zh-hans (Ubuntu)
Undecided
Unassigned

Bug Description

ttf-wqy-microhei is installed in Lucid by default. However... the system is not using this font as the default chinese font. it's using an ungly chinese font... sometimes,bitmap fonts are used. it looks weird.
hope this can be fix soon.

Yunkwan (chanyunkwan0217) wrote :
Adam Guthrie (therigu) on 2010-04-04
tags: added: lucid
Xhacker Liu (xhacker) wrote :

This bug affects me too. Please use microhei by default instead of zenhei.

Xhacker Liu (xhacker) on 2010-04-09
affects: ubuntu → language-support-zh-hans (Ubuntu)
Changed in language-support-zh-hans (Ubuntu):
status: New → Confirmed
Aron Xu (happyaron) on 2010-04-09
affects: language-support-zh-hans (Ubuntu) → language-support-fonts-zh-hans (Ubuntu)
Changed in language-support-fonts-zh-hans (Ubuntu):
status: Confirmed → New
Aron Xu (happyaron) wrote :

Assigning Arne to have a look.

tags: added: fonts
removed: lucid
Changed in ubuntu-translations:
assignee: nobody → Arne Goetje (arnegoetje)
importance: Undecided → Medium
status: New → Triaged
leeaman (leeaman1977) wrote :

microhei better zenhei better uming fonts

lewvip (lewvip-163) wrote :

microhei is much beautiful ,Please use it as the default font.

DENY IT!

I never used to microhei for text reading.

2010/4/9 lewvip <lewvip@163.com>

> microhei is much beautiful ,Please use it as the default font.
>
> --
> default chinese font isn't ttf-wqy-microhei
> https://bugs.launchpad.net/bugs/555184
> You received this bug notification because you are a member of Ubuntu
> Simplified Chinese Translators, which is subscribed to language-support-
> fonts-zh-hans in ubuntu.
>

Xhacker Liu (xhacker) wrote :

@luojie-dune: We just want to use microhei as a GUI font. It is really better than zenhei. (much better than the ugly bitmap...)

feiy (eshangrao) wrote :

+1

Qianqian Fang (fangq) wrote :

On 4/9/2010 9:30 AM, Xhacker Liu wrote:
> @luojie-dune: We just want to use microhei as a GUI font. It is really
> better than zenhei. (much better than the ugly bitmap...)
>

please do not mix two issues together:

the original report seems to be an issue of prioritizing Japanese
fonts above Chinese ones: the text was clearly rendered by
Japanese-styled Han glyphs (likely vlgothic). This should be
fixed by using the language-specific fontconfig files that Arne is
working on, (or the current language-selector/fontconfig-voodoo
approach).

Arne, can you give an update on this?

the second issue is the preference between microhei/zenhei, or
microhei/bitmap song for Han glyphs. Admit it or not, this is
just a matter of personal taste. It is fine to advocate the preference
you like, but please also show your respect to the alternative
opinions too. Using strong words such as "ugly" can actually
bring negative feelings to your feedback.

I think this bug is already mixed two issues. The reporter said "the system is not using this font as the default chinese font". For the second issue, i personally think bitmap should not appear in a modern operating system. And microhei is more beauty than zenhei. In Ubuntu China forum, many users think microhei is the best Chinese font in Ubuntu.

Qianqian Fang (fangq) wrote :

On 04/10/2010 12:19 AM, Dsegun Ludice wrote:
> I think this bug is already mixed two issues. The reporter said "the
> system is not using this font as the default chinese font".

all I am saying is we need to tease apart the
bug bits from a wishlist. Issue 1 is a bug, issue 2 is
a wishlist. I bet you can not solve issue 1 solely
by bumping the priority of microhei; because if you
do that, Japanese Kanji will be shown in microhei,
and it will be another bug.

> For the
> second issue, i personally think bitmap should not appear in a modern
> operating system.

I agree that this is likely true for Latin fonts, but for
Chinese, this was not that clear, at least not as many non-CJK
developers thought it was. The only data we have related
to Chinese font preference is the poll at Ubuntu Chinese
forum a few years ago. It showed a 7:3 split for
vector:bitmap preferred users from >300 voters.
True, bitmaps users are minority, but I won't call
30% negligible.

Yunkwan (chanyunkwan0217) wrote :

then, why not write a script to let people change the default Asian font
easily? like the im-swtich script that let us switch the default input
method.

On Sat, Apr 10, 2010 at 1:50 PM, Qianqian Fang <email address hidden> wrote:

> On 04/10/2010 12:19 AM, Dsegun Ludice wrote:
> > I think this bug is already mixed two issues. The reporter said "the
> > system is not using this font as the default chinese font".
>
> all I am saying is we need to tease apart the
> bug bits from a wishlist. Issue 1 is a bug, issue 2 is
> a wishlist. I bet you can not solve issue 1 solely
> by bumping the priority of microhei; because if you
> do that, Japanese Kanji will be shown in microhei,
> and it will be another bug.
>
> > For the
> > second issue, i personally think bitmap should not appear in a modern
> > operating system.
>
> I agree that this is likely true for Latin fonts, but for
> Chinese, this was not that clear, at least not as many non-CJK
> developers thought it was. The only data we have related
> to Chinese font preference is the poll at Ubuntu Chinese
> forum a few years ago. It showed a 7:3 split for
> vector:bitmap preferred users from >300 voters.
> True, bitmaps users are minority, but I won't call
> 30% negligible.
>
> --
> default chinese font isn't ttf-wqy-microhei
> https://bugs.launchpad.net/bugs/555184
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu Translations (internationalization and localization):
> Triaged
> Status in “fontconfig” package in Ubuntu: New
> Status in “language-selector” package in Ubuntu: New
> Status in “language-support-fonts-zh-hans” package in Ubuntu: New
>
> Bug description:
> ttf-wqy-microhei is installed in Lucid by default. However... the system is
> not using this font as the default chinese font. it's using an ungly chinese
> font... sometimes,bitmap fonts are used. it looks weird.
> hope this can be fix soon.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/555184/+subscribe
>

Pan, SZ (pan.sz) wrote :

In fact, Fang Qian has written a gtk+ based gui application for this.

Though I personally think it is way too overkill to write a gui
application for this simple task, a less-than-5-line CLI script is
enough for this. At least the CLI does not introduce gtk+ dependency
to kde users.

On Sat, Apr 10, 2010 at 4:18 PM, Yunkwan <email address hidden> wrote:
> then, why not write a script to let people change the default Asian font
> easily? like the im-swtich script that let us switch the default input
> method.
>
> On Sat, Apr 10, 2010 at 1:50 PM, Qianqian Fang <email address hidden> wrote:
>
>> On 04/10/2010 12:19 AM, Dsegun Ludice wrote:
>> > I think this bug is already mixed two issues. The reporter said "the
>> > system is not using this font as the default chinese font".
>>
>> all I am saying is we need to tease apart the
>> bug bits from a wishlist. Issue 1 is a bug, issue 2 is
>> a wishlist. I bet you can not solve issue 1 solely
>> by bumping the priority of microhei; because if you
>> do that, Japanese Kanji will be shown in microhei,
>> and it will be another bug.
>>
>> > For the
>> > second issue, i personally think bitmap should not appear in a modern
>> > operating system.
>>
>> I agree that this is likely true for Latin fonts, but for
>> Chinese, this was not that clear, at least not as many non-CJK
>> developers thought it was. The only data we have related
>> to Chinese font preference is the poll at Ubuntu Chinese
>> forum a few years ago. It showed a 7:3 split for
>> vector:bitmap preferred users from >300 voters.
>> True, bitmaps users are minority, but I won't call
>> 30% negligible.
>>
>> --
>> default chinese font isn't ttf-wqy-microhei
>> https://bugs.launchpad.net/bugs/555184
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in Ubuntu Translations (internationalization and localization):
>> Triaged
>> Status in “fontconfig” package in Ubuntu: New
>> Status in “language-selector” package in Ubuntu: New
>> Status in “language-support-fonts-zh-hans” package in Ubuntu: New
>>
>> Bug description:
>> ttf-wqy-microhei is installed in Lucid by default. However... the system is
>> not using this font as the default chinese font. it's using an ungly chinese
>> font... sometimes,bitmap fonts are used. it looks weird.
>> hope this can be fix soon.
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/ubuntu-translations/+bug/555184/+subscribe
>>
>
> --
> default chinese font isn't ttf-wqy-microhei
> https://bugs.launchpad.net/bugs/555184
> You received this bug notification because you are a member of Ubuntu
> Simplified Chinese Translators, which is subscribed to language-support-
> fonts-zh-hans in ubuntu.
>

Arne Goetje (arnegoetje) wrote :

I have updated the font preferences for Chinese in fontconfig-voodoo, shipped with language-selector to prefer microhei.

Changed in language-selector (Ubuntu):
status: New → Fix Released
Changed in language-support-fonts-zh-hans (Ubuntu):
status: New → Invalid
Changed in fontconfig (Ubuntu):
status: New → Confirmed
Arne Goetje (arnegoetje) on 2010-09-06
Changed in ubuntu-translations:
assignee: Arne Goetje (arnegoetje) → nobody

arne, can you explain why the zh-* selectors do not have the <test name="lang"> comparison like the one in ja-jp?

Arne Goetje (arnegoetje) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 05/08/2011 03:23 AM, Ahmad Syukri wrote:
> arne, can you explain why the zh-* selectors do not have the <test
> name="lang"> comparison like the one in ja-jp?
>
At the time when the files were made, the <test name="lang"> test didn't
work reliably, at least I couldn't get it to work. If it works reliably
now and you can give me a test case which proves this, then I can change it.
However, I would rather prefer to have a consensus in Debian/Ubuntu on
how to handle the fontconfig configuration in general. Upstream
fontconfig includes a list of more or less suitable fonts, but sais the
distribution should adjust the list if necessary. Neither Debian nor
Ubuntu do that currently and leave everything to the font package
maintainers. I'm unhappy with this situation and would like to get this
solved once and for all.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBCAAGBQJNxc/TAAoJENiwmJtstTzshEEQAJF7ua1qxPqfoQ3QPaal+YrE
WGrwNONmSCuVPozZeqZj4J45058QbYPuMQ9qlUvYc+BLHcHohHk8iTY4+KrxWEI9
dZg281EsOfMAsRtUg3lOJc/O8NwjJb+pfHdTpeBTYJv9kehRlYAWtkYTm2J2xEvQ
xtAwvPbR8ey00SHGgtZCqZ6ybG4LOj/VzXPWdQB5iSOh76+ciR//h7jyIM9X9TMI
gShhHqHjT1hMd3kdn4OuBIloPfMRm2izQJLFvJciLu54C1oW00WD1WGvn8vW9UaH
do7DAbovWX0YSUGZILF2sKozFOgpnm3yWe5IhfObB0Emi9coMttU9kTs3ym9Ay89
kRklfpm653n3t7CKE07OXk/XkFd7apGxbIHplvskobrp8t6QNNd6IedgCStHfwG/
EszKWgS7kmmFXITHPL/uk15Jh4XfxJY8EvOuPk6jNaLKhe0tC0ogmZAl3rYT8wCl
wRMSIG6JDiA+6/PvZspFUz37fl+cf8jR7PhKP3cBtynVMOWbR6pKuqdlBXl0mX43
k6kHrJd8HEtOED085TEOTij7bYY6jkLDcaRLGzQ86o8QkY5XEXBCO0eaTJSglVc/
jd3/+seUkQ2MGF4iaJMpmqonJjgOvChFLN16DhLp4fA1VWiM8Vzh3lwcFjmjYuUU
GBtWE2grWyO4gyOwTtRg
=qt9Q
-----END PGP SIGNATURE-----

Qianqian Fang (fangq) wrote :

On 05/07/2011 03:23 PM, Ahmad Syukri wrote:
> arne, can you explain why the zh-* selectors do not have the<test
> name="lang"> comparison like the one in ja-jp?

Making language-selector-zh-* Chinese specific will leave 65-nonlatin
the only one active to set CJK font proprieties under non-CJK locales
(such as en_US etc).

Sadly, 65-nonlatin is terribly outdated, and put Japanese fonts in front
of Chinese ones; this causes the famous mosaic problem when viewing
a block of Chinese text in these locales, see

https://bugs.freedesktop.org/attachment.cgi?id=24321
http://picasaweb.google.com/fangqq/ConfigScreenshot#5333302146968242258

New 65-nonlatin has been proposed by no one in the upstream
to pay serious attention. You can find more discussions here:

https://bugs.freedesktop.org/show_bug.cgi?id=20911
https://bugzilla.redhat.com/show_bug.cgi?id=499902

Arne Goetje (arnegoetje) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 05/08/2011 07:12 AM, Qianqian Fang wrote:
> Making language-selector-zh-* Chinese specific will leave 65-nonlatin
> the only one active to set CJK font proprieties under non-CJK locales
> (such as en_US etc).

Yep, and one more thing:
language tagging only works if the text which is displayed is _also_
tagged with the correct language code.
In an ideal world every application and every text would be tagged with
the correct language code and the rendering engine would choose the
correct font for every language.
Configuring fontconfig to do so is only one part of the story. The next
step would be to hunt down every application which does not support
language tagging and does not have proper fontconfig integration. And
this includes content management systems which are used on the web. And
then you would need to check all kind of websites if they use proper
language tagging or not, and report to the webmaster if they don't. (And
then hope that they will fix it, which they probably won't.)

The fontconfig configuration can (and probably should) be fixed in each
distribution (we can coordinate this if upstream doesn't bother). But
this doesn't mean that CJK rendering will automatically be improved.

For hunting down applications which don't comply, filing bugs upstream
and maybe sending patches, we would need some volunteers (probably a
team) to do that efficiently... and some coordination of course. Anyone?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBCAAGBQJNxdnxAAoJENiwmJtstTzscIUQALcdOiSjMw0u60i3QRjJmXi2
TbJWkGbIOeJStpY/cpNEgohJrffMw//Gz5VxatBJG00v8lT6tIy+9jBOpUOWdDaB
+cGt9jrmNZ5GhbK28xm3FeDXl4b61INneqaTFCUB8aldjTEySsW+i2XYfXw5MCcI
LJzM7LzbF81p1VGjFc+ZcMnf/vImZ8HN3f4FJsCDWeag+iaWbXrPF9RjSwyAzQ5c
NW15ZdqPTcWOTh3bHWt3ayQyAbPEEQ5aMEqHgP2inKCJWztrRaSQluoOJw+QU9wv
EzrYbR7oc2MJ8jFlKufMyLgxGh2B6g4iGua3yoD6Wj13LUG3l4F+OP2S23wPQloK
wQIRXXw3a/H5nTUKt5jJltiEqkm2Jwbjy5E5anTH5AqHgbfv6vZOcRDm6imnsgj2
+f0pT9fW8Uc7sy6SiRKt5yXsGlwKPGxb0WONYMG2eNB688rpvKhCoy4vZtOST1iO
dd0oPDej0+vBkhDd1jPpiu7iPm22bxFnBwynG0iJsqpQCaxI2m+8zRDQ2BIu7Lvc
C4yLPvBIBImpGsOkGiEWm9EzJDVpFWfJk6dEyDO8jCVkaIJcWQOoIt6IFiQ8GJsp
EWIDI8LIlRiXe7EbM6ckOXl4Z4HlYcAToOPo5igRoG3uL6MkrIi+QkkBzmICNT2p
pefCmQwCpApfNBS0ZPtu
=DFj1
-----END PGP SIGNATURE-----

Changed in ubuntu-translations:
assignee: nobody → Ubuntu Simplified Chinese Translators (ubuntu-l10n-zh-cn)
Aron Xu (happyaron) on 2013-10-14
Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in fontconfig (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.